If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

PM fills in password, but asks if I want to save password.

RESOLVED WORKSFORME

Status

()

Toolkit
Password Manager
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: jsado_sc5, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.6) Gecko/20040326 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.6) Gecko/20040326 Firefox/0.8

I go to a site that has a login/password (bugzilla.mozilla.org). The login and
password is filled in. I click on login and then Firefox asks me if I want it to
remember the password.

This should not happen, of course since to get to this point I must have already
said yes once before.

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
Works for me using
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040505
Firefox/0.8.0+
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040505

Comment 2

13 years ago
I'm seeing this in Firefox 9.1

I am using a profile which is somewhat imported from Mozilla.  Not sure if that
is related to the problem at all.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041017 Firefox/1.0

WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 4

12 years ago
I can confirm this bug still exists on Firefox 1.5beta1, and Mozilla 1.7.8 on
win98/2k. Please reopen this and correct the appropriate fields.

I can reproduce it on www.atlas.sk. I have *2* logins/passwords stored for this
site. When I go to the site, firefox prefills nothing (correctly, how should it
decide?). Fill in one of my usernames. Firefox does nothing. I then click the
checkbox under the login form. Suddenly, firefox fills in the correct password.
I klick submit, and firefox asks if I wish to save the password (which it
already knows).
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.