If the inline element that is on block box that establishs the new block formatting context and has width:auto is positioned relatively by :hover, the height of parent block box becomes the same as that of first line height

RESOLVED FIXED

Status

()

Core
Layout: Block and Inline
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: masayuki, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040502
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040502

If the inline element that is on block box that establishs the new block
formatting context(e.g., having flot is not 'none' or position is 'absolute' and
overflow is not 'visible') and has width:auto(initial value) is positioned
relatively by :hover, the height of parent block box becomes the same as that of
first line height.

this bug becomes bugzilla-jp
http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=3761

I create the same test cases.

test case1: http://bugzilla.mozilla.gr.jp/attachment.cgi?id=2205&action=view
In this case, most simple test case by float.
Hover to the every lines, the parent block element(border is 'red' and float is
'left') is resize to its first line height, except for "overflow: visible;" case.

test case2: http://bugzilla.mozilla.gr.jp/attachment.cgi?id=2206&action=view
In this case, the width of block elements is not 'auto'.
This case is works fine.

test case3: http://bugzilla.mozilla.gr.jp/attachment.cgi?id=2207&action=view
The :hover is set to only last line of the every paragraph.

test case4: http://bugzilla.mozilla.gr.jp/attachment.cgi?id=2210&action=view
The :hover is set to only 3rd and 4th lines(color and border is 'blue') of the
every paragraph. The lines is two element(by every line).

test case5: http://bugzilla.mozilla.gr.jp/attachment.cgi?id=2211&action=view
The :hover is set to only 3rd and 4th lines(color and border is 'blue') of the
every paragraph. The lines is one element.

test case6: http://bugzilla.mozilla.gr.jp/attachment.cgi?id=2212&action=view
This is same as that of test case1. However, the first line of every box are
having "line-height: 3em".
The height of parent boxies will be 3em.

test case7: http://bugzilla.mozilla.gr.jp/attachment.cgi?id=2213&action=view
This is same as that of test case6. However, the all block boxies have
"position: absolute;"(not floating boxis).

Reproducible: Always
Steps to Reproduce:
1. See the above test cases.
2. Move to the text that is in the box that border is red.
3.

Actual Results:  
In some cases, the height of block boxis are resized to its first line height.

Expected Results:  
In all cases, the height of block boxis are not resized.
roc, this depends on your scrollframe refactoring, I'd say....

Comment 3

14 years ago
Confirming on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20040925 Firefox/0.10.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Testcases fail for me with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.8b2) Gecko/20050422 Firefox/1.0+
Testcases works for me with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.8b2) Gecko/20050428 Firefox/1.0+
Resolved Fixed by bug 240276
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.