Firefox Help does not use the default OS X theme properly

RESOLVED FIXED in mozilla1.8beta2

Status

RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: MMx, Assigned: kevin)

Tracking

({fixed-aviary1.0})

unspecified
mozilla1.8beta2
PowerPC
Mac OS X
fixed-aviary1.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 4 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040506 Firefox/0.8.0+ (MMx2000)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040506 Firefox/0.8.0+ (MMx2000)

The help window in Firefox does not use the default OS X theme (Pinstripe)
properly. It is kind of a mix between Qute and Pinstripe.

Reproducible: Always
Steps to Reproduce:
1.Open Help window
2.See for yourself ;-)

Actual Results:  
Help window looks kinda ugly

Expected Results:  
fully use Pinstripe
(Reporter)

Comment 1

15 years ago
Created attachment 147814 [details]
Screenshot

attached Screenshot of my latest MOZILLA_1_7_BRANCH nighty Help Viewer. (same
UA as above)
(Reporter)

Updated

15 years ago
Flags: blocking1.0?
The viewer isn't fully themed yet, kevin gerich is working on it.

This is a dupe of wherever that original bug is, can't look right now. :)
Flags: blocking1.0?
Whiteboard: DUPEME
(Reporter)

Comment 3

15 years ago
I found it on my own.
Because this Bug is already "RESOLVED FIXED", it didn't show up in my first search. 
But I am still seeing the problem. So is it fixed now or not?

*** This bug has been marked as a duplicate of 231741 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
Reopening bug.

mconnor: It depends on your definition of fixed :). It is fixed in the sense
that it displays Pinstripe theme.

I'm actually not seeing a problem from this screenshot. What about the Help
Viewer looks incorrect?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

15 years ago
 The problem based on his screen shot... I would think is three fold...

1.) The Back/Fwd & Home buttons boarders are blacked... they should have a
lighter outline... with a shadow..

2.) The printer doesn't appear to have a alpha channel.

3.) The Qute throbber

They stick out compared the rest of the theme... and that’s just to start with...
(Reporter)

Comment 6

15 years ago
I agree to the observations of Comment #5, but have to add:
The button bar should look like the one of the window behind it. (same height,
button spacing, etc. 
To me it seems that the Help Viewer still uses the Qute theme, just with the
Pinstripe artwork.

Comment 7

15 years ago
Confirming Bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

15 years ago
Confirming Bug.

This bug is not a duplicate of any bug. If there are any other bugs filed for
this, than mark it as a dupe of this bug (unless you have a good reason otherwise).
Whiteboard: DUPEME
Asking for blocking. Should be fixed in the "aquifition" release
Flags: blocking1.0?

Comment 10

15 years ago
Reporter: I recently checked in some Help Viewer UI changes and it might fix
this bug. Since I'm not on MacOS I can't test it.

Can you get a recent trunk build of Firefox and tell me if it fixes the issues
you reported?

Thanks!
Status: NEW → ASSIGNED

Comment 11

15 years ago
Created attachment 149044 [details]
screen shot of 20040519 build

It seems that the same problem as bug243428 has occurred.
And There is no button of Go/Back...

trunk build:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP; rv:1.8a) Gecko/20040519
Firefox/0.8.0+
(Reporter)

Comment 12

15 years ago
I wanted to test it with a more recent nighty, but the 2004-05-21 does not start. :(
Have to wait for fresh builds...

Comment 13

15 years ago
Created attachment 149437 [details]
screen shot of 20040528 AVIARY_1_0_20040515_BRANCH

Appearance is bad and some errors have also come out.

Mac OS X 10.3.4
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040528
Firefox/0.8.0+

Comment 14

15 years ago
Created attachment 150199 [details]
screen shot of 20040607 AVIARY_1_0_20040515_BRANCH

Appearance is still bad.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040607
Firefox/0.8.0+
Flags: blocking1.0? → blocking1.0mac+

Comment 15

15 years ago
There was no Help in Mac version Firefox 0.9 RC.
(depend bug240277 ?)

Since there is this bug, doesn't Help include the release version, either?

Comment 16

15 years ago
crot0: Can you send me a recent screenshot of this through email? There have
been so many skih changes that it's hard to find bugs with these older screenshots.

I have a feeling that this bug could've been fixed from the theme change.

Comment 17

15 years ago
(In reply to comment #16)
> crot0: Can you send me a recent screenshot of this through email? There have
> been so many skih changes that it's hard to find bugs with these older
screenshots.

Keller-san,
Although sauce was brought and built from AVIARY_1_0_20040515_BRANCH today, it
is the same as the screen shot appended to the following last.
http://bugzilla.mozilla.org/attachment.cgi?id=150199&action=view
(Reporter)

Comment 18

15 years ago
(In reply to comment #17)

> Although sauce was brought and built from AVIARY_1_0_20040515_BRANCH today, it
> is the same as the screen shot appended to the following last.
> http://bugzilla.mozilla.org/attachment.cgi?id=150199&action=view

I can confirm this. build today (2004-06-12) shows the same behaviour.

Another strange thing:
All the recent official Mac nighties (including 0.9RC1) do *not* contain the help!
What the hell is going on there? I use nearly the same configure arguments  and
I have help!

(In reply to comment #18)
> All the recent official Mac nighties (including 0.9RC1) do *not* contain the
> help!

See bug 244479.

Comment 20

15 years ago
Created attachment 151204 [details]
screen shot of 20040619 AVIARY_1_0_20040515_BRANCH

It is repaired that the button etc. was displayed distorted.
However, the icon of a tool bar is visible to the thing for Windows.
(With the Mac version, the go/back button is light-blue.)
Attachment #149437 - Attachment is obsolete: true
Attachment #150199 - Attachment is obsolete: true

Comment 21

15 years ago
crot0: So you are saying that the toolbar images just have to be changed? If
this is true, I should be able to fix this quickly.

Comment 22

15 years ago
(In reply to comment #21)
> crot0: So you are saying that the toolbar images just have to be changed? If
> this is true, I should be able to fix this quickly.

Although I do not understand about the portion which creates a jar file, it
seems to have packed the thing of windows.

Comment 23

15 years ago
Moving to new Firefox Help owner.
Assignee: rlk → jwalden+fxhelp
Status: ASSIGNED → NEW
Is this still a problem?  Without a Mac, I can't test it.

Comment 25

15 years ago
Created attachment 158303 [details]
screen shot of AVIARY branch 20040909

The icon of a tool bar seems to be satisfactory.
But the scroll arrow at the bottom right of a window has hidden.

Updated

15 years ago
Attachment #151204 - Attachment is obsolete: true

Updated

15 years ago
Attachment #149044 - Attachment is obsolete: true
(In reply to comment #25)
> The icon of a tool bar seems to be satisfactory.
> But the scroll arrow at the bottom right of a window has hidden.

I don't understand what you're saying.  Do you mean that the scroll arrow
shouldn't be shown?  Anyways, the shot looks exactly as I'd expect it to look on
a Mac.  Can you give another screenshot that demonstrates the problem by a
comparison of a good app and Help?

Comment 27

15 years ago
http://bugzilla.mozilla.org/attachment.cgi?id=147814&action=view

Please see the bottom right of a browser window on the back.
The arrow for carrying out vertical scrolling of the usual window is displayed.
But The down arrow is hidden in the window of a help.

A problem will be divided if this is the problem which is not related to theme.
Okay, so it sounds like the window's missing a scrolling arrow.  Forwarding to
someone who actually knows how to fix this...
Assignee: jwalden+fxhelp → webmail
*** Bug 260874 has been marked as a duplicate of this bug. ***
Kevin, any chance we can get it for 1.0?
(Assignee)

Updated

14 years ago
Keywords: fixed-aviary1.0
looks more improved using 2004110310-0.11 bits.
Version: unspecified → 1.0 Branch

Comment 32

14 years ago
It seems that in Forefox 1.0 everything is fixed now. I believe this bug should
marked as fixed.
moving blocking1.0mac bugs to Firefox1.1 Target Milestone.
Target Milestone: --- → Firefox1.1
Work on the aviary branch for 1.0 has been transferred into trunk code, so I
assume this is fixed in trunk code.  If there are further problems, please file
new bugs.
Status: NEW → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Component: Help Viewer → Help Viewer
Flags: blocking-aviary1.0mac+
Product: Firefox → Toolkit
Target Milestone: Firefox1.1 → ---
Version: 1.0 Branch → unspecified

Comment 35

14 years ago
Targetting bugs which were targetted to Firefox1.1 before the move to
mozilla1.8beta2.
Target Milestone: --- → mozilla1.8beta2
Product: Toolkit → Seamonkey
You need to log in before you can comment on or make changes to this bug.