All users were logged out of Bugzilla on October 13th, 2018

Special Character Entities Do Not Require Semicolon

RESOLVED INVALID

Status

RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: dougall, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040309
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040309

If the semicolon is left off character entities like "&trade" and "&amp" Mozilla
will still display the special character.

While in most cases this is what the user meant, in some cases it might not be.

The SGML definition does state that the semicolon is sometimes optional
(http://www.w3.org/TR/html4/charset.html#entities).

Reproducible: Always
Steps to Reproduce:
1. create an html file with &trade with no semicolon
2. open this html file in Mozilla


Actual Results:  
the trademark symbol is displayed

Expected Results:  
&trade should be displayed because the semicolon is missing

Comment 1

15 years ago
Like you said yourself, the trailing semicolon can be optional in some cases, as
the spec outlines.

Unless you have a testcase where the semicolon should have been required and the
entity rendered despite no semi-colon, this is not a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.