Performance degrades after application has been mimimized and other applications have run

RESOLVED INVALID

Status

Thunderbird
Mail Window Front End
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: David, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)

I've noticed that Thunderbird seems to become sluggish when it has been
minimized or "covered" and other applications have been run. For example, I'm
finished checking my mail, I use a browser, a graphics program, Office
applications... When I want to use Thunderbird again and click on its "start
bar" icon, the application takes quite some time (10 seconds to over 30 seconds)
to re-paint itself and the controls don't seem to recognize click events for
similar intervals (though the events are not lost). Gradually, the application
performance comes back to normal.

The behavior does not seem to be related to the use of other specific
application and other applications do not seem to exhibit the same behavior.

Reproducible: Always
Steps to Reproduce:
1. Use Thunderbird.
2. Open and close many other applications for about 1/2 hour 
3. Click on Thunderbird icon
Actual Results:  
1. Thunderbird takes more than 15 seconds to re-paint
> After the menu's have been repainted, click on an action such as "Write", "Get
Mail" or a specific folder.... 
2. Thunderbird can take up to 10 seconds to recognize the event.

Expected Results:  
re-established itself promptly

I am using Windows XP (home edition) on 1.5G P4 with a mere 256megs of RAM -- so
memory may be an issue. I have noticed similar problems with Netscape (7.1) and,
in fact, the reason that I started to use Thunderbird (instead of the Netscape
mail client) was that, after a day or so of use, Netscape needed to be
terminated and restarted
(Assignee)

Comment 1

14 years ago
when you minimize an application on winxp it gets swapped out memory. 

The delay you see is the OS swapping us back into memory
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.