Mousewheel scrolling broken on framed pages

RESOLVED FIXED in mozilla1.7final

Status

()

Core
Event Handling
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: Simon Fraser, Assigned: Brian Ryner (not reading))

Tracking

({regression})

Trunk
mozilla1.7final
regression
Points:
---
Bug Flags:
blocking1.7 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
I'm seeing broken mousewheel scrolling on some pages with frames. The mousewheel
events seem to be scrolling a frame which is not under the mouse. Clicking to
focus the frame under the mouse doens't help.

Steps:
1. go to wired.com
2. position mouse over the middle of the page
3. move scrollwheel

Notice that the horizontal frame at the top of the page is getting scrolled, not
the page content.
(Reporter)

Comment 1

14 years ago
Pretty serious regression. Was seen in trunk build, unclear if it applies to the
branch.
Target Milestone: --- → Camino0.8

Comment 2

14 years ago
I see this, too, using 2004050308 (v0.8b). It’s not the ad frame, but rather the
Terra Lycos bar at the very top. It scrolls very slightly at the first
scrollwheel detente, then since that frame is now at the bottom subsequent
scroll detentes scroll the entire page.

Same happens when direction is reversed; first the top frame is scrolled to the
top, then the page gets the clicks.

Note that on cursory examination, that top frame is built by their ad code.
can we figure when this regressed?
Keywords: regression

Comment 4

14 years ago
Testing now…

Comment 5

14 years ago
Between Camino 2004-02-27-08 and Camino 2004-02-28-08.
ookie, what landed on that date that busted stuff?
(Reporter)

Comment 8

14 years ago
The fix for bug 229371 looks like the most promising candidate.
has anyone tested ff to see if the regression happens there too?

Comment 10

14 years ago
It doesn’t seem to happen using Moz/1.7b (2004042110).
bryner says this happens on linux too. probably should block 1.7
Assignee: pinkerton → bryner
Component: General → Event Handling
OS: MacOS X → All
Product: Camino → Browser
Hardware: Macintosh → All
Target Milestone: Camino0.8 → mozilla1.7final
Version: unspecified → Trunk
Flags: blocking1.7?

Updated

14 years ago
Flags: blocking1.7? → blocking1.7+
(Assignee)

Comment 12

14 years ago
I'm not able to reproduce this now on the trunk or branch.

Comment 13

14 years ago
appears to not be reproducable now.  maybe they changed content on wired?  
would need a test case, confirmed bug, and ideas on a patch to hold for 1.7... 
 renominate if anyone still sees this. 
Flags: blocking1.7+ → blocking1.7-
i still see it on wired.com's homepage. very easy to repro.
Flags: blocking1.7- → blocking1.7?

Comment 15

14 years ago
I'm using the latest 1.7 nightly and wasn't able to reproduce the bug with the
steps mentioned in the description.
Page content is getting scrolled without problems.

Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.7) Gecko/20040531
Sounds (from talking to bryner) like it can't be reproduced outside of Camino
right now, so not a 1.7 blocker.
Flags: blocking1.7? → blocking1.7-
Maybe bug 256538 fixed this too?
(In reply to comment #17)
> Maybe bug 256538 fixed this too?

It would appear so. Resolving fixed unless anyone can still reproduce; I cannot.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.