firefox.exe process doesn't terminate properly

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: lotti, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; H010818)
Build Identifier: Mozilla Firefox 0.8

Whenever I close or exit Firefox, the firefox.exe process still appears in Task 
Manager. If I then re-start Firefox it comes up with Select User process window 
and doesn't allow me to start Firefox. I have only one profile and msg is that 
Profile is in use. I can only re-start firefox by killing the process in Task 
Manager. However if a firefox browser is still open, I can execute firefox.exe 
multiple times to bring up new browser sessions.

Reproducible: Always
Steps to Reproduce:
1.Start Firefox
2.Kill Firefox (File -> Close) or hit the X
3.Note firefox.exe still in Task manager
4. Try to re-start Firefox

Actual Results:  
Select User Profile panel appears asking to choose a profile. I have "Don't ask 
at startup" checked. There's only one profile available and highlighted 
(default) so when I choose to Start firefox, get msg "Firefox cannot use the 
profile default because it is in use. Please choose another profile or create a 
new one." If I make a new profile then I can start Firefox.

Expected Results:  
firefox.exe should be removed from list of processes in Task Manager when 
firefox window is closed.

Comment 1

15 years ago
WFM.

- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040507
Firefox/0.8.0+
- Microsoft Windows 2000 Pro 5.00.2195 SP4
(Reporter)

Comment 2

15 years ago
I de-installed a product called Infuzer (www.infuzer.com) which copies data 
from online services (eg travel itineraries) into my calendar, and the problem 
went away. Bizarre
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 3

15 years ago
Nothing in Mozilla/Firefox was broken or fixed.

->WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

15 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.