<div> Code that uses "drop-down" information does not work; appears as simple text

VERIFIED INVALID

Status

()

Core
Layout
VERIFIED INVALID
14 years ago
14 years ago

People

(Reporter: Sean Dempsey, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

In the page http://marge.uvm.edu/sdempse/alternative.htm there are categories 
of artists. When clicked on in IE 5.0, for example, it "drops-down" a list of 
other text and links. For mozilla, the categories only appear as straight text.

Reproducible: Always
Steps to Reproduce:
1.go to http://marge.uvm.edu/sdempse/alternative.htm
2.click on any of the categories (ie an artist's name)
3.the links do not "drop down" as they should on other browsers

Actual Results:  
no effect. that's the problem

Expected Results:  
a list of links and text should have immediately dropped into place below the 
category (artist name).

this is code that uses the <div> tags. The function that makes it work as a 
drop down menu is found at the bottom of the page 
<http://marge.uvm.edu/sdempse/alternative.htm>

Comment 1

14 years ago
Javascript console says:
> Error: window.event has no properties
> Source File: http://marge.uvm.edu/sdempse/alternative.htm
> Line: 1853

window.event is an IEism.

since reporter == page author, this is INVALID (not a Mozilla bug)
http://qsdqsd.free.fr/Dev_model/Html%20JavaSript/Compatible%20JavaScript%20IE-Mozilla.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.