Firefox sometime breakes compressed css on ssl sites

RESOLVED DUPLICATE of bug 222457

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 222457
14 years ago
14 years ago

People

(Reporter: Alexander Gruber, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

i have found a bug in firefox i think. it sometimes doesn´t use css files. but
this only happens when the css files are compressed via mod_deflate in apache2
(v2.0.49) and it is an SSL-ENABLED site. it also happens when you refresh the
page the css file is used correctly. 
the css files a corretly delivered as text/css. i have not experienced any
problems in the non-ssl area or with any other browser (opera, konqueror,
internet explorer), just with firefox, mozilla and netscape. 



Reproducible: Sometimes
Steps to Reproduce:
1. connect to a ssl-enabled site that uses mod_deflate and delivers compressed
css-files



Actual Results:  
sometimes the css files are not used

Comment 1

14 years ago
Do you have a site I could test this on?

Comment 2

14 years ago
a dupe of bug 222457?
(Reporter)

Comment 3

14 years ago
Created attachment 148334 [details]
screenshot of correct css file usage
(Reporter)

Comment 4

14 years ago
Created attachment 148335 [details]
screenshot of incorrect css file usage
(Reporter)

Comment 5

14 years ago
(In reply to comment #2)
> a dupe of bug 222457?

seems to be, but there isn´t a solution to bug 222457, isn´t it?

you can test it on http://admin.fuchs.ws this will redirect you to an
ssl-enabled site. i found out with the live-http-header extension that the cache
has to be set to 0kb so that the css is not stored locally.
most of the time the css is not used when you first enter the site. if it is,
just close the browser and try again. that sometime "solves" it and the css is
not used. 
you can see the differences between correct and incorrect usage at the attached
screenshots "right.jpg" and "wrong.jpg".
(Reporter)

Comment 6

14 years ago
(In reply to comment #2)
> a dupe of bug 222457?

hello? does anybody work on this bug?
(Reporter)

Comment 7

14 years ago
(In reply to comment #6)
> (In reply to comment #2)
> > a dupe of bug 222457?
> 
> hello? does anybody work on this bug?

as nobody from the firefox team seems interested in fixing bugs i´ll close the
testsite now! :-(

Comment 8

14 years ago
Very similar to bug 222457 so I'm marking as RD.

*** This bug has been marked as a duplicate of 222457 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.