messages get lost / swap positions

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: Sander Van de Moortel, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040424 Firefox/0.8
Build Identifier: Thunderbird 0.6 (20040502)

I have an IMAP account - not verified on POP.
I have also set my thunderbird to download any message from the server when
checking for mail.

But quite often, I open my message and another message appears (sometimes the
next thread, sometimes a message of an earlier date, ..). It also happens that a
message is completely lost. Very irritating and high-priority since I lose mail.

All I can do is delete the locally stored files and re-download everything from
the server, which will usually fix the problem. Thank god for IMAP, but even
then a regular user won't figure out how to fix this.

Reproducible: Sometimes
Steps to Reproduce:
1. just wait, it happens.
Actual Results:  
The message window opened a wrong message, i had to click on the next one in
order to open the previous message. In some cases I don't find the right message
back at all.

Expected Results:  
Open the right message, if it'd be so kind.

Comment 1

14 years ago
Created attachment 165750 [details]
Additional notes-similar problems-screenshot attached

Using OS 10.3.5 and Thunderbird version 0.9 (20041103) on a PowerBook G4, I had
a similar problem ... an email listed in my inbox, when I clicked on it to open
it had a completely different header info -- different sender, subject, and
body (text) -- didn't match at all. I could not find the actual body to the
listed email in any email in my inbox. Had to email sender to send again. 

Also, have one or two each day of blank lines in my inbox yet I can delete
them, but they show no subject and no sender -- just a blank entry in the list.


Please email me to let me know when this is fixed -- or email me to let me know
if I have to come back and check to see when fixed. Thanks!!
(Reporter)

Comment 2

14 years ago
I am not completely sure, but I have been experiencing this bug quite often in
the past, too. I think the problem may be caused because you have multiple
e-mailaccounts which are all set to download to the same local folder. Ever
since I stored my downloaded e-mails locally in a different folder (one for each
account), I have not experienced the problem again.

Let me know what your findings are.

Comment 3

14 years ago
I've been able to trigger this problem by deleteing more than once message at a
time.

Comment 4

13 years ago
This has happened twice to me. The first time, I thought it must be a virus or a worm, but I found nothing. When it happened again, I searched the bug database, and found this report. 

I have permanently lost many (20-50, I'm not sure) e-mails, and this is a very serious problem for me. If it happens again, I shall have to stop using Thunderbird; I just can't afford the risk. 

It seems that parts of other messages are overwriting the original message text, or in some cases deleting the message text completely (header included, exept for the title). This only seems to happen in the inbox of the default account (I have many folders, and several account set up). 

I'm now using 1.0.7, and upgraded (from 0.something) between the two incidents, so this has happened in at least two versions. 

If someone is willing to look at this, I can send copies of the scrambled messages. I know very little about programming, so I'm afraid I can not help in any other way. 

Best regards,
Tom Einar Andersen

Comment 5

12 years ago
gone? Or still a problem if you use Thunderbird v1.5?

Comment 6

12 years ago
(In reply to comment #4)
> This has happened twice to me. The first time, I thought it must be a virus or
> a worm, but I found nothing. When it happened again, I searched the bug
> database, and found this report. 
> 
> I have permanently lost many (20-50, I'm not sure) e-mails, and this is a very
> serious problem for me. If it happens again, I shall have to stop using
> Thunderbird; I just can't afford the risk. 
> 
> It seems that parts of other messages are overwriting the original message
> text, or in some cases deleting the message text completely (header included,
> exept for the title). This only seems to happen in the inbox of the default
> account (I have many folders, and several account set up). 
> 
> I'm now using 1.0.7, and upgraded (from 0.something) between the two incidents,
> so this has happened in at least two versions. 
> 
> If someone is willing to look at this, I can send copies of the scrambled
> messages. I know very little about programming, so I'm afraid I can not help in
> any other way. 
> 
> Best regards,
> Tom Einar Andersen

Tom, 
I rather suspect your problem is not related to this plus I expect this bug will be closed.  Suggest you upgrade and experiment with TB v1.5. If it still happens then search for another related bug and if you don't find one create a new bug.
(Reporter)

Comment 7

12 years ago
I don't think I ever experienced it again since I made separate folders for the local database, as described somewhere in my post. I have used thunderbird 1.5 shortly (now I'm completely on g-mail's webmail, that's one less programme to run), but I don't think there were any issues with 1.5 either.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.