Firefox fails to start after using custom installation on XP SP1

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Mr. I. M. Williams, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.6) Gecko/20040206 Firefox/0.8

After installing Firefox 0.8 using custom installation to folder C:\Program
Files\Mozilla\Firefox choosing the option to include "Developer Tools" (the
"Additional Browsing Enhancements" option was greyed out and therefore
unavailable), Firefox failed to start both under the automatic start option at
the end of the install and independently even after a reboot. At the first
attempt (after each clean re-install) the folder "chrome" was created under
Phoenix\*** in "Documents and Settings". Chrome was empty. When I uninstalled
Firefox beween each installation attempt, I also deleted the "Phoenix" folder.
Allowing the installer to use the "Standard" install produced a working
installation at the first attempt.

Reproducible: Always
Steps to Reproduce:
1.Run installer
2.Choose Custom setup option
3.Select/create installation folder C:\Program Files\Mozilla\Firefox
4.Choose additional components:- Developer Tools
5.Complete installation and leave "Start Firefox" ticked

Actual Results:  
Firefox fails to start and display browser window, but did create the "chrome"
folder.
Does not show up in "Windows Task Manager" as a running application.

Expected Results:  
Firefox should have started up and displayed a browser window.

Comment 1

14 years ago
Did you have any previous installation in that folder? Did you disable the
extensions before updating?
(Reporter)

Comment 2

14 years ago
Additional Comment #2)
The folder "Firefox" was new and created specifically for the installation of
Firefox 0.8.
This folder together with the "Phoenix" folder was removed, after uninstalling
Firefox, before each following attempt.
It was the first time I had tried installing Firefox (or Firebird) on this PC
(or any of my systems), so I do not believe "disabling the extensions" is
relevant since I was not performing an update.

(In reply to comment #1)
> Did you have any previous installation in that folder? Did you disable the
> extensions before updating?

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.6)
Gecko/20040206 Firefox/0.8
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.6)
Gecko/20040206 Firefox/0.8
> 
> After installing Firefox 0.8 using custom installation to folder C:\Program
> Files\Mozilla\Firefox choosing the option to include "Developer Tools" (the
> "Additional Browsing Enhancements" option was greyed out and therefore
> unavailable), Firefox failed to start both under the automatic start option at
> the end of the install and independently even after a reboot. At the first
> attempt (after each clean re-install) the folder "chrome" was created under
> Phoenix\*** in "Documents and Settings". Chrome was empty. When I uninstalled
> Firefox beween each installation attempt, I also deleted the "Phoenix" folder.
> Allowing the installer to use the "Standard" install produced a working
> installation at the first attempt.
> 
> Reproducible: Always
> Steps to Reproduce:
> 1.Run installer
> 2.Choose Custom setup option
> 3.Select/create installation folder C:\Program Files\Mozilla\Firefox
> 4.Choose additional components:- Developer Tools
> 5.Complete installation and leave "Start Firefox" ticked
> 
> Actual Results:  
> Firefox fails to start and display browser window, but did create the "chrome"
> folder.
> Does not show up in "Windows Task Manager" as a running application.
> 
> Expected Results:  
> Firefox should have started up and displayed a browser window.

(In reply to comment #1)
> Did you have any previous installation in that folder? Did you disable the
> extensions before updating?

(In reply to comment #1)
> Did you have any previous installation in that folder? Did you disable the
> extensions before updating?

Comment 3

14 years ago
Build too old to be of use.  Try to reproduce on FF 0.9 or a nightly.

Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.