Pagedown/Pageup broken for some pages (Firefox 0.8)

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Thomas Passin, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

In the page at http://www.epa.gov/OWOW/NPS/MMGI/Chapter4/ch4-5b.html, and many
others but not all, Pageup/Pagedown fail to operate correctly.  Exact results
are erratic, but typically Pagedown will move down one or two screens, then may
return to the top,  near the top, or just jump down and then back to the
previous position.  Pageup suffers from similar behavior.

The same page works normally in Mozilla 1.7a on the same computer.

I have some extensions installed, including Adblock and the Flash blocker, but
even with those turned off I got the same behavior.

Much as I like Firefox, which is my default browser, this behavior is really
difficult to tolerate.  Unfortunatly, I have not discovered what features of a
page are associated with this behavior.

I am reporting this for Firefox 0.8 on Windows 2000, but it was present in at
least some predecessors.  It is present in all three Firefox installations I
have on three different computers.

Reproducible: Always
Steps to Reproduce:
1. Load problem page, such as the URL given above.
2.  Click in the content area to make sure that the Pagedown keystroke will be
registered.
3. Press the Pagedown key (either the one on the numeric keypad or the other
one).  Repeat Pagedown  until either you get to the bottom of the page or you
notice that the page does not move down one page as required.

You may find that the exact (mis)behavior changes as you continue to press
Pagedown.  Pageup displays similar incorrect functioning.



Actual Results:  
For the first three Pagedown keystrokes, the page moved normally.  On the
fourth, it jumped several pages in the wrong direction, but not all the way to
the top.  After this, for each Pagedown keystsroke, the page jumped down and
immediately returned the the same location it had before the keypress.

Even after I scolled down several screens by clicking in the scrollbar, the page
returned the the same place it had stuck on before when I again pressed Pagedown.

Expected Results:  
The page should have jumped down towards the bottom one screen at a time.
Works for me using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a)
Gecko/20040509 Firefox/0.8.0+

Please try installing into a new directory and creating a new profile and report
your results here

QA Contact: mconnor

Comment 2

14 years ago
Works for me using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a)
Gecko/20040521 Firefox/0.8.0+

Please use a current nightly build before reporting bugs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.