Drag of column header divider causes Messenger to freeze

VERIFIED FIXED in M13

Status

P3
critical
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: fenella, Assigned: joki)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Linux Redhat 6.0 (1999-01-18-11 M13)
Win32 (1999-01-18-11 M13)
Mac (1999-01-18-13 M13)
Steps:
1. Launch Messenger using the -mail option
2. From my Inbox, select a message, message displays. No problem.
3. Mouze over the column header divider and try to resize the column.

Actual result: The cursor changes to a cross on Linux and Mac. It changes to a
two-head arrows on Win_nt 4.0. (I know, it does not resize the column width, see
bug 24078)

4. set cursor in the Thread pane again and try to select a message
Actual result: It does not allow me to select a message, Messenger freezes. I
have to exit and restart Messenger

Expect result: It should not freeze even though the resizing column does not
work.

This occurs on all 3 platforms both in the POP/IMAP accounts.
(Reporter)

Comment 1

19 years ago
Note: Mouse was mis-spelled as mouze.
It still freezes even if I skip step 2.

Updated

19 years ago
Assignee: phil → hyatt
Severity: normal → critical

Comment 2

19 years ago
Reassign to hyatt, and bumping severity to critical.

Updated

19 years ago
Status: NEW → ASSIGNED
Summary: Mouse over column header divider causes Messenger to freeze → Drag of column header divider causes Messenger to freeze
Target Milestone: M13

Comment 3

19 years ago
Comments to beard/joki:

The details:
(1) I have a view associated with the header of a tree widget (a table row).  Up
until recently, this had always worked fine.
(2) When the user begins dragging a column header to resize the column, I call
GrabMouseEvents on this view.
(3) Mouse events would go to this view, which would end up going to my tree row
frame, and I'd handle the column resizing.

What happens now:
The view becomes the mouse grabber, but my frame never gets ANY events.
Furthermore, because I'm locked in some
kind of grabbing mode, I can't get out of it, and the whole window gets frozen.
 Something has to have changed recently
regarding the flow of events through views, frames, and presshells, or with
views themselves to cause this regression.  This
worked about a week ago (the last time I checked it).

Any cycles or help that the two of you could spare would be most appreciated.
If you suspect that it has nothing to do with
you, let me know if you have any ideas about who I should be picking on instead.
:)  I know I didn't touch the tree code, so
I don't think it's that.
(Assignee)

Updated

19 years ago
Assignee: hyatt → joki
Status: ASSIGNED → NEW
(Assignee)

Comment 4

19 years ago
Yeah, this is my fault.  Part of a fix for event handling with hidden divs.
I'll back out my fix.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

19 years ago
Fix checked in.
(Reporter)

Comment 6

19 years ago
Linux Redhat 6.0 (2000-01-20-08 M13)
Win_nt 4.0 (2000-01-20-09 M13)
Mac (2000-01-20-08 M13)
This problem is fixed in POP and IMAP on all 3 platforms.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 7

19 years ago
*** Bug 24501 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.