If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

unable to log into usaa.com with firefox, but mozilla/IE both work

RESOLVED DUPLICATE of bug 291052

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 291052
14 years ago
12 years ago

People

(Reporter: Daniel Quinlan, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040506 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040506 Firefox/0.8

When I fill in my correct USAA number and password on this page, then
click on the "Log On" button, absolutely nothing happens.  If I leave
both fields blank, then clicking does work, but that obviously isn't too
helpful if you're trying to log on.

I tried Mozilla 0.6 instead of Firefox, then I'm able to log in just fine
and clicking on the button works.

I have JavaScript turned on and cookies allowed for the site.

The Mozilla browser that works is:

  Mozilla 1.6, Copyright (c) 2003 mozilla.org, build 2004042607


Reproducible: Always
Steps to Reproduce:
1. load http://www.usaa.com/
2. page redirects to https://www.lc.usaa.com/inet/lcs_corp/Logon (or similar the
   name of the page changes occasionally)
3. fill in USAA member number and password
4. click on "Log On", nothing happens

I expect if you try a random number and password, the same will happen.
The USAA member number is typically 7 numbers (all digits) and my password
is 6 letters (mixed numbers and lowercase letters).

Actual Results:  
nothing happens

Expected Results:  
successful login to site


IE also works.

I am using the password manager, but clearing the information and typing it
in again does not change the result.
(Reporter)

Updated

14 years ago
Summary: when number and password entered, click on "Log On" button does nothing → unable to log into usaa.com with firefox, but mozilla/IE both work
Works for me using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a)
Gecko/20040510 Firefox/0.8.0+

Is there any errors in the javascript console?
(Reporter)

Comment 2

14 years ago
> Is there any errors in the javascript console?

No errors or warnings.
(Reporter)

Comment 3

14 years ago
Just a bit more information:

when I say nothing happens, truly nothing happens.  No page is loaded, the
whatever-that-is in the upper right hand corner doesn't spin, the button is
dead as a doornail.
When attempting to connect to www.usaa.com using both Firefox .8 and .9, I get
an error message from the site saying the page is unavailable.  Mozilla,
Netscape, IE, Konqueror work properly.  After hitting the refresh button, the
normal login screen appears.  I can then login; however, randomly throughout the
site, I am told that pages do not exist, and I am kicked out.  In particular,
links that should create a pop-up window, instead redirect the main window to an
error screen.  For example
https://www.gc.usaa.com/inet/gas_corp/CpGlossary?Cond=browser&area=Investing&topic=brokerage&term=margin+account&ReferringUrl=https://www.im.usaa.com/inet/gas_imco/StaticPages#glossaryLink

Should create a pop-up window.  Instead I am redirected to a search screen,
though the URL stays the same.
https://www.gc.usaa.com/inet/gas_corp/CpGlossary?Cond=browser&area=Investing&topic=brokerage&term=margin+account&ReferringUrl=https://www.im.usaa.com/inet/gas_imco/StaticPages#glossaryLink

When I enter search criteria, I am bounced out of the site with an error page:
https://www.im.usaa.com/inet/gas_imco/StaticPages

All of this works fine with other browers.  There are no errors in the Java
Script console.  

I am using .9 on Windows XP.  I should be able to test .9 on Linux this weekend.
this sounds like the famous submit button not working bug.
Can't find the # anymore :-(

Comment 6

12 years ago

*** This bug has been marked as a duplicate of 291052 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.