Bookmarks Menu / Bookmarks Toolbar are Empty

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: ali, Assigned: p_ch)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Sometime between 2004-05-09 00:00 and 2004-05-10 07:30 PDT, something broke that
is causing the Bookmarks Menu and Bookmarks Toolbar to be empty. The
bookmarks.html file itself appears to be intact.

This bug seems to affect Linux only.
(Reporter)

Comment 1

15 years ago
Setting blocking0.9+, no question that this is a blocker.
Flags: blocking0.9+
if it regressed then, is it on the branch as well?
Confirmed. Dai Toyama's 20040510 P4/SSE2 build also shows the bug.

Comment 4

15 years ago
Confirmed myself, as Bradley kindly reported for me.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a) Gecko/20040509 Firefox/0.8.0+
(daihard: XFT+GTK2; opt. for P4/SSE-2)

Comment 5

15 years ago
P.S. My build is really 2004-05-10, though the build string says it's
2004-05-09. The build started around 11:50 PM PDT on May 9.

Comment 6

15 years ago
I should point out that if you go to Bookmarks > Manage Bookmarks and then close
the bookmark manager, the Bookmarks menu thereafter is normal, however the links
toolbar is not.
(Reporter)

Comment 7

15 years ago
Oops, I jumped the gun on the flag. It doesn't affect the branch (well not as of
Mon May 10 15:19:53 PDT 2004, anyway). Removing blocking0.9+ flag.
Flags: blocking0.9+
(Reporter)

Comment 8

15 years ago
I wonder if the root cause of this bug is the same as that of bug 243262.

Comment 9

15 years ago
(In reply to comment #6)
> I should point out that if you go to Bookmarks > Manage Bookmarks and then close
> the bookmark manager, the Bookmarks menu thereafter is normal, however the links
> toolbar is not.

Well, not quite normal.  Even after I do that, the "Open in Tabs" menu item is
missing.

Comment 10

15 years ago
I think this is only affecting clobber builds. I have a depend build with a
checkout as of Wed May11 close to midnight UTC and I don't see this

Comment 11

15 years ago
http://forums.mozillazine.org/viewtopic.php?t=76261 says this is fixed.  Is that
true?

Comment 12

15 years ago
It seems to have been fixed.  I just made a build with a cvs checkout of:

checkout start: Wed May 12 16:52:06 MST 2004

Unlike builds yesterday, the bookmarks menu and toolbar are populated.
(Reporter)

Comment 13

15 years ago
My build of Wed May 12 18:59:54 CDT 2004 has this fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

15 years ago
*** Bug 244879 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.