random cleanup in nsInternetSearchService

RESOLVED FIXED in seamonkey2.0a1

Status

SeaMonkey
Search
P4
normal
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: Benjamin Smedberg, Assigned: Benjamin Smedberg)

Tracking

Trunk
seamonkey2.0a1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

14 years ago
nsInternetSearchService has global comptrs that could be and should be member
vars (the rdf service and various rdf resources). I discovered this accidentally
while leaking domwindows.
(Assignee)

Comment 1

14 years ago
Created attachment 148127 [details] [diff] [review]
Make static comptrs into member vars.
(Assignee)

Updated

14 years ago
Attachment #148127 - Flags: superreview?(bryner)
Attachment #148127 - Flags: review?(axel)

Comment 2

14 years ago
Comment on attachment 148127 [details] [diff] [review]
Make static comptrs into member vars.

I find it a bit inconsistent to rename some of the former globals to mFoo while
others remain kFoo.
Attachment #148127 - Flags: superreview?(bryner) → superreview+
(Assignee)

Updated

13 years ago
Priority: -- → P4
Target Milestone: --- → mozilla1.9alpha
(Assignee)

Comment 3

12 years ago
Pike, I'd like to clean this up, can you make a decision of some sort for me?
(Assignee)

Comment 4

12 years ago
*** Bug 318929 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

12 years ago
Created attachment 205377 [details] [diff] [review]
Updated to trunk

Axel, I'm happy to make the global kFoo -> mFoo change before checkin, but it would make this patch impossible to review. If I make that global change, I'll go ahead and fix all the indentation while I'm at it.
Attachment #148127 - Attachment is obsolete: true
Attachment #205377 - Flags: review?(axel)
Attachment #148127 - Flags: review?(axel)

Updated

12 years ago
Attachment #205377 - Flags: review?(axel) → review+
(Assignee)

Comment 6

12 years ago
Fixed on trunk.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: Core → SeaMonkey

Updated

9 years ago
Target Milestone: mozilla1.9alpha1 → seamonkey2.0a1
You need to log in before you can comment on or make changes to this bug.