incorrect windows version detected

VERIFIED INVALID

Status

()

VERIFIED INVALID
15 years ago
14 years ago

People

(Reporter: brant, Assigned: darin.moz)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 9.4; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 9.4; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

I used Microsoft's Application Verifier (free) to spoof the Windows version to
Firefox.  It then detects Windows as version 9.4 instead of 7.2.4500 that I
spoofed it to be.

Reproducible: Always
Steps to Reproduce:
1. Spoof the version to Firefox.
Actual Results:  
The version of Windows in the usersagent string is incorrect.

Expected Results:  
The version should be 7.2 which is what I spoofed it to be.
See
http://lxr.mozilla.org/seamonkey/source/netwerk/protocol/http/src/nsHttpHandler.cpp#621
 -- the code looks fine to me... What does this spoofer of yours actually set?
Assignee: general → darin
Component: Browser-General → Networking: HTTP
QA Contact: general → core.networking.http
(Reporter)

Comment 2

14 years ago
Here is the description of the High Version Lie test that is on MSDN: The
HighVersionLie test's primary purpose is to ensure that applications that run on
Windows XP will run correctly as future versions of Windows are released. This
test is NOT intended for internal system components or applications that ship
with the OS. Running this test on the aforementioned components will cause
unforeseen results as these components expect a certain version to be returned.
This test is designed for applications that will perform version checking and
will respond based on the operating system version information returned.

The test is configurable to enable you to provide the major version, minor
version, and build number that should be returned to the application.

This test hooks all calls to GetVersion and GetVersionEx.

A debugger is not required.

The MSDN page is
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnappcom/html/appverifier.asp?frame=true
(Assignee)

Comment 3

14 years ago
Brant: I don't see a bug here.  We are using the standard WIN32 API GetVersionEx
to determine the OS version.  Are you suggesting that we call some other
function?  If so, please explain.  Thanks.  Otherwise, this bug seems invalid.
(Reporter)

Comment 4

14 years ago
I did some further testing and it seems to be a flaw in the Application Verifier
program.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 5

14 years ago
V/invalid.
Status: RESOLVED → VERIFIED
QA Contact: networking.http → benc
You need to log in before you can comment on or make changes to this bug.