Closed Bug 243225 Opened 21 years ago Closed 21 years ago

The forms windows on the Bugzilla bug report page acts chaotic with garbage and broken scrolling.

Categories

(Camino Graveyard :: HTML Form Controls, defect)

PowerPC
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 222972

People

(Reporter: webmaster, Assigned: mikepinkerton)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030306 Camino/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030306 Camino/0.7

Running G5 Dual 2gig CPU OS 10.3.3 dual monitors, one in 800x600 and the other
in 1024x768.  Build ID: 2003030613

I call up this bug report page and the "most common bugs listed" window/table
will scroll down with the scroll wheel (MS Mouse) but as the lines of text move
up the window the text no longer matches the cell areas and overlaps badly.
http://alaskaoutdoorjournal.com/Camino/tablemismatchBOTTOM.gif Once reaching the
bottom of the table list, the text below/outside the table of text has multiple
layers of text over itself. (see link above) The scroll wheel - when the mouse
pointer remains inside the bug list table - will not scroll the table contents
UP once the scroll bar hits the bottom limit in its column. Scroll wheeling
outside the table on the page moves the whole page up and sometimes placing the
mouse back inside the bug list table the scroll wheeling will begin to work UP
again and other times it won't. If it allows scrolling back to the top of the
table list, there is overlapping text at the top.
http://alaskaoutdoorjournal.com/Camino/tablemismatchTOP.gif

Also on this bug report form page, when I selected the COMPONENT topic, the
entire list went white when I selected a topic with just a yellow highlight.
Dropdowns for Hardware Platform and Operating System right below that Component
area were overwriting with all the dropdown text displaying in a glob. Example
screen shot: http://alaskaoutdoorjournal.com/Camino/vanishedtextandoverwrite.gif

Just encountered another thing which may already be reported. When the cursor
has been placed inside a text entry window, the scroll wheel will only work on
lines within the text entry window. Typically when a scroll wheel reaches the
TOP or BOTTOM of the window the entire page then begins to scroll. This does not
happen with Camino on this bug report page. You must click outside the text
entry box to allow wheel scrolling of the page.

Reproducible: Always
Steps to Reproduce:
1. Use  dual G5, 10.3.3, Camino .7 booted. Go to Report a Bug link.
2. Scroll down the page to the table with listed bugs and use the mouse wheel to 
scroll down the table list to the end. Then with the mouse pointer still in the
table window, try using the scroll wheel to go back UP the table list. 
3. Move mouse outside of table and scroll with wheel. Page moves. Then try
inside table. Sometimes it will scroll content other times not. Watch for 
reported text overlap at top and bottom of bug list table window.

I've rebooted Camino a couple of times and this has been reproduced each time.

Actual Results:  
All the reported "symptoms" are displayed on the page.

Expected Results:  
Should have performed normal scrolling inside the table window. Should not have
overwritten text in gobs.  Dropdown lists should not be printed on the page as
an overwritten text smear.
Probably a dup of bug 222972. Gary, please retest using a current nightly build
and if the problem no longer occurs resolve this bug as a duplicate.
a combo of our two panther issues probably.

*** This bug has been marked as a duplicate of 222972 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.