HTML Tag: BGPROPERTIES="FIXED" does not work in Camino 0.7

VERIFIED DUPLICATE of bug 7474

Status

VERIFIED DUPLICATE of bug 7474
15 years ago
4 years ago

People

(Reporter: webmaster, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030306 Camino/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030306 Camino/0.7

The FIXED condition as a page background properties does not work. This tag,
bgproperties="fixed" is found in the BODY tag element and its function is to
freeze the background image in the browser display so that only the text and
graphical content of the page will scroll up and down.

This conditional tag works fine in IE and Safari on Mac.

Reproducible: Always
Steps to Reproduce:
1. Go to referenced URL and scroll on the page using Camino and then Safari or IE
2. You will see the spiral notebook background image does not scroll with the
page when using Safari and IE but Camino does not lock the background during
scrolling.
3.

Actual Results:  
See above

Expected Results:  
Locked background image and only scrolled page contents.

Comment 1

15 years ago
BGPROPERTIES is a nonstandard Microsoft HTML extension and is not supported by
Mozilla. Use W3C-standard style="background-attachment: fixed;" CSS instead for
full cross-browser support.

Reassigning to Evangelism.

(Gary: since your e-mail address is also at alaskaoutdoorjournal.com, I assume
you’re the page’s developer. Your BODY tag is presently:

<body bgcolor=white background="../Images/spiralbrwn.jpg" font color=black
LINK=#008400 VLINK=#996600 BGPROPERTIES="FIXED">

Instead, change it to:

<body bgcolor="white" background="../Images/spiralbrwn.jpg" color="black"
LINK="#008400" VLINK="#996600" style="background-attachment: fixed;">

Note that I removed the extraneous and unnecessary 'font' as well.
Alternatively, you could employ even further CSS, resulting in:

<body LINK="#008400" VLINK="#996600" style="background: white
url(../Images/spiralbrwn.jpg); color: black; background-attachment: fixed;">

Good luck!)
Assignee: pinkerton → english-us
Status: UNCONFIRMED → NEW
Component: Page Layout → English US
Ever confirmed: true
Product: Camino → Tech Evangelism
QA Contact: english-us

Comment 2

15 years ago
Since there are other bugs about this, resolving as dup of one of the earliest.

*** This bug has been marked as a duplicate of 7474 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.