sourceid parameter is not passed in default quick search

VERIFIED WORKSFORME

Status

()

Firefox
Search
--
enhancement
VERIFIED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Rain maker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When using the default quick search, firefox translates "google foo" to
"http://www.google.com/search?&q=foo"

When using the search location bar, it gets translated to
"http://www.google.com/search?q=foo&sourceid=mozilla-search&start=0&start=0&ie=utf-8&oe=utf-8"

Especially the sourceid parameter is of interest. I personally think it's a good
thing for the mozilla community to include this parameter in the default quick
search. Maybe make it firefox-search instead of mozilla-search.

I know it's just a small thing, but this might give a clearer picture of the
amount of people actually using mozilla / firefox

Reproducible: Always
Steps to Reproduce:
1. Open a new tab
2. Type in the adressbar: "google foo"
3. Now click in the small search box to the right, enter "foo" and hit enter

Actual Results:  
when using the location bar, the sourceid parameter is not passed to google

Expected Results:  
Pass it
you're using the keyword bookmark from the default bookmarks.  You can modify 
that if you want, since these bookmarks are only read into your profile when 
you create the profile.  

http://lxr.mozilla.org/seamonkey/source/browser/app/profile/bookmarks.html 
shows that the sourceid is part of the current base bookmarks.html, so new 
users/profiles will pass that parameter.

The URL in your quick search bookmark should be changed to 
http://www.google.com/search?&q=%s&sourceid=mozilla-search to match the current 
implementation.

Resolving WORKSFORME since this has already been changed, but I don't think 
there's a bug for it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Assignee: p_ch → nobody
Status: RESOLVED → VERIFIED
QA Contact: search
You need to log in before you can comment on or make changes to this bug.