Menus are disabled after Customize Toolbars until browser is restarted

RESOLVED FIXED

Status

()

Firefox
Toolbars and Customization
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: Ali Ebrahim, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
UA: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a)
Gecko/20040510 Firefox/0.8.0+

Menus are disabled after Customize Toolbars until browser is restarted. This
problem appears to occur on Linux only.

Steps to Repro:
1a. View | Toolbars | Customize
-or-
1b. Right-click on a toolbar, Customize.
2. Do something (or nothing).
3. Press Done.

Expected Results:
Menus should work okay.

Actual Results:
Menus are disabled until browser is restarted.

I have a feeling this *may* have the same root cause as bug 243210, but I'm not
sure on that. Regression window appears to be similar. Today's builds do not
work, yet builds from 2004-05-08 do not have problems.

Comment 1

14 years ago
(In reply to comment #0)
I'm also having the same problem.
Reproduced with the same steps.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a) Gecko/20040510 Firefox/0.8.0+

Comment 2

14 years ago
This does not happen with build 20040509 on Win2k.
Confirmed on Linux. I was forced to return to a 20040507 build, which is NOT
broken. The build ID of the broken build is:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a) Gecko/20040510 Firefox/0.8.0+
(daihard: XFT+GTK2; opt. for P4/SSE-2)

One bug that may be related to this is bug 243210, which also appeared in the
build enumerated above.

Comment 4

14 years ago
Confirming this aswell, Linux.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a) Gecko/20040510 Firefox/0.8.0+

Comment 5

14 years ago
http://forums.mozillazine.org/viewtopic.php?t=76261 says this is fixed.  Is that
true?
(Reporter)

Comment 6

14 years ago
My build of Wed May 12 18:59:54 CDT 2004 has this fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
*** Bug 247594 has been marked as a duplicate of this bug. ***

Updated

12 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.