crash when tab-navigating to a textarea

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: k-sound, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

There is a problem with the tab jump, when you use the tab-button to jump from 1
field to an other the browser crashes when you reach the textarea. Possibly a
conflict in the jump index 

Reproducible: Always
Steps to Reproduce:
1. click in on of the text fields
2. press the tab button until you get to the textarea

Actual Results:  
complete crash , CPU at 100%
(Reporter)

Updated

15 years ago
Summary: crash when tab-navigating to a textarea → crash when tab-navigating to a textarea

Comment 1

15 years ago
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040510
Firefox/0.8.0+

Please only file bugs with builds not older than 2 weeks. Retest with nightly
buiild and a fresh profile.

Comment 2

15 years ago
Tabbing through all the fields WFM on yesterday's trunk Win32 build. FWIW,
tabbing through the fields on your testcase does not take me to the main textarea.

Someone might want to test this on the branch too, but I don't have any branch
builds available right now.

Comment 3

15 years ago
No crash, but I also never get to the text area when tabbing through the fields
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040511
Firefox/0.8.0+

probably because there's a
onFocus="this.blur();"
in one of the text input fields.

Comment 4

14 years ago
No crash. I also never get to the text area when tabbing through the fields.

- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2) Gecko/20040525
Firefox/0.8.0+
- Microsoft Windows 2000 Pro 5.00.2195 SP4

Comment 5

14 years ago
this snippet illustrates the crash when you tab from first box to second:

<table>
<tr>
<td><input type=text></td>
<td><input type=text onFocus="this.blur();"></td>
</tr>
</table>

Comment 6

14 years ago
Mark, that testcase worksforme, what build are you testing with?
(Reporter)

Comment 7

14 years ago
in recent builds the crash problem seems to be fixed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 8

14 years ago
Correcting resolution.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.