When querying LDAP servers that allow anonymous bind, password dialog box continues to appear.

RESOLVED DUPLICATE of bug 242772

Status

RESOLVED DUPLICATE of bug 242772
15 years ago
14 years ago

People

(Reporter: melevittfl, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: version 0.6 (20040502)

When querying LDAP servers that allow anonymous bind, password dialog box
continues to appear. Leaving the password empty allows the query to succed, but
the next time you compose a message, password dialog reappers. 

Checking "remember password" does not save the empty password.

Reproducible: Always
Steps to Reproduce:
Configure a connection to an LDAP address book that allows anonymous (empty
password) access. 

Open a compose window and start typing a name.

Password dialog appears. Check "Use Password Manager to remember this password"

Click OK to submit an empty password. 

Lookup succeds. 

Close Compose window.

Open a new Compose window and start typing a name.
Actual Results:  
A password dialog box appears.

It seems that it is not able to save the fact that the LDAP server doesn't need
a password.

Expected Results:  
Lookup succeds without prompting for a password.

I first reported this under Mozilla 1.6 MailNews, but I discovered that
Thunderbird has the same bug and I wasn't sure if anyone is tracking/handling
MailNews bugs anymore.
(Assignee)

Comment 1

15 years ago
can we dupe this against hte mozilla bug then? WE don't keep thunderbird
specific dupes of bugs.
(Reporter)

Comment 2

15 years ago
The corresponding bug against Mozilla 1.6 is:
http://bugzilla.mozilla.org/show_bug.cgi?id=242772

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 242772 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.