Closed Bug 243372 Opened 20 years ago Closed 20 years ago

[port]GTK2 theme menuitem support from Firefox classic skin

Categories

(Core Graveyard :: GFX: Gtk, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ginnchen+exoracle, Assigned: ginnchen+exoracle)

References

Details

Attachments

(3 files, 2 obsolete files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20040406
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20040406

Port -moz-appearance: menuitem to Mozilla Classic theme

Reproducible: Always
Steps to Reproduce:
1.Choose classic theme
2.Change your native GTK2 theme
3.Restart mozilla, notice the menuitem background, not as good as firefox
Attached patch Menu.CSS patch (obsolete) — Splinter Review
Port some sections from firefox to gtk2
There is no menu.css in global/unix/. Just add to global/win/
Attachment #148271 - Flags: review?(p_ch)
Depends on: 118296
Attachment #148271 - Flags: superreview?(bryner)
Attachment #148271 - Flags: review?(p_ch)
Attachment #148271 - Flags: review?(neil.parkwaycc.co.uk)
Assignee: themes → ginn.chen
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #148271 - Attachment is obsolete: true
Attachment #148271 - Flags: superreview?(bryner)
Attachment #148271 - Flags: review?(neil.parkwaycc.co.uk)
Status: NEW → ASSIGNED
Component: Themes → GFX: Gtk
Attachment #149804 - Flags: superreview?(roc)
Attachment #149804 - Flags: review?(mkaply)
Attachment #149804 - Flags: superreview?(roc) → superreview+
Thanks for the sr=
I'll update the patch because firefox's theme is changing a bit for bug 244955,
bug 174740
Comment on attachment 149804 [details] [diff] [review]
a better patch after 237535's checkin

I'm going to give this one to bryner
Attachment #149804 - Flags: review?(mkaply) → review?(bryner)
Comment on attachment 149804 [details] [diff] [review]
a better patch after 237535's checkin

I'm plussing this because I don't see a problem, but in general you need to be
very careful when using the preprocessor on CSS files.	It can strip out id
selectors (starting with #) as comments.  Only if it's at the beginning of the
line though, and I don't see anything in this file that would be affected.
Attachment #149804 - Flags: review?(bryner) → review+
Yes, I know that.
Create a new theme directory for mozilla/gtk2 would be better.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
(In reply to comment #7)
>Create a new theme directory for mozilla/gtk2 would be better.
Which will be simplified once jar.mn preprocessing is in.
OK, this is not good. the spacing between menu items is too large in mozilla.
this looks rather ugly, especially in comparison to native gtk2 apps, or just to
firefox.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Also, in bluecurve, the current menuitem does not change the text color to white
as it does in firefox.
This seems to fix the padding problem:

Index: menu.css
===================================================================
RCS file: /cvsroot/mozilla/themes/classic/global/win/menu.css,v
retrieving revision 1.52
diff -u -r1.52 menu.css
--- menu.css    25 Jun 2004 07:42:31 -0000      1.52
+++ menu.css    28 Jun 2004 19:29:58 -0000
@@ -136,9 +136,13 @@
 /* ::::: menu/menuitems in menubar ::::: */
  
 menubar > menu {
+#ifdef MOZ_WIDGET_GTK2
+  padding: 0px 6px 0px 4px;
+#else
   border: 1px solid transparent;
   padding: 2px 5px 2px 7px;
   margin: 1px 0px 1px 0px;
+#endif
 }
  
 menubar > menu[_moz-menuactive="true"] {
@@ -173,7 +177,9 @@
 popup > menu,
 menupopup > menuitem,
 popup > menuitem {
+#ifndef MOZ_WIDGET_GTK2
   padding: 2px;
+#endif
   max-width: 42em;
 }
(In reply to comment #10)
> Also, in bluecurve, the current menuitem does not change the text color to white
> as it does in firefox.

I guess bug 244955 will fix both Firefox and Mozilla for this point. For now,
Mozilla is using gtk2-hovertext, Firefox is using HighlightText, they both does
something wrong with certain theme.
I'll check it later.
(In reply to comment #10)
> Also, in bluecurve, the current menuitem does not change the text color to white
> as it does in firefox.

HighlightText not work with Gnome-Simple theme, please check bug 244955.
*** Bug 249013 has been marked as a duplicate of this bug. ***
What about the padding issue?
(In reply to comment #16)
> What about the padding issue?

looks good to me, pls get somebody review it.
Attachment #151891 - Attachment is obsolete: true
Attachment #152011 - Flags: superreview?(roc)
Attachment #152011 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #152011 - Flags: review?(neil.parkwaycc.co.uk) → review?(bryner)
Attachment #152011 - Flags: superreview?(roc) → superreview+
I tried the latest patch.
It seems good to me too.
Attachment #152011 - Flags: review?(bryner) → review+
somebody checkin the padding patch please?
padding fix checked in
Checking in themes/classic/global/win/menu.css;
/cvsroot/mozilla/themes/classic/global/win/menu.css,v  <--  menu.css
new revision: 1.53; previous revision: 1.52
done

marking fixed again
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: