firefox gtk2 doesn't start at all

RESOLVED DUPLICATE of bug 243315

Status

()

Toolkit
Startup and Profile System
--
critical
RESOLVED DUPLICATE of bug 243315
14 years ago
9 years ago

People

(Reporter: gandalf, Assigned: Benjamin Smedberg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Firefox 0.8+ nightly 20040511 
Linux Slackware 9.1 
 
bash-2.05b# ./firefox 
bash-2.05b# ./firefox-bin 
./firefox-bin: error while loading shared libraries: libmozjs.so: cannot open 
shared object file: No such file or directory
(Reporter)

Comment 1

14 years ago
same with version from 20040512 linux gtk2+xtf 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
Severity: normal → critical

Comment 2

14 years ago
Is this the same as bug 243315?  That one doesn't have an error message.

Comment 3

14 years ago
Is libmozjs.so actually missing? Try looking in the components directory for it
if you don't see it in the main directory.

Running ./firefox-bin doesn't set all the necessary environment variables for
firefox to start. I noticed you get no error just running ./firefox which is the
script to set the variables.
(Reporter)

Comment 4

14 years ago
running ./firefox results in nothing. silence. no process run.
(Reporter)

Comment 5

14 years ago
still same problem with gt2k version from 20040516
(Reporter)

Updated

14 years ago
Summary: firefox doesn't start because of lack of libmozjs.so → firefox gtk2 doesn't start at all
(Reporter)

Comment 6

14 years ago

*** This bug has been marked as a duplicate of 243315 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.