All users were logged out of Bugzilla on October 13th, 2018

Crash when trying to access a link [@ nsChildView::GetParent]

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: suishouen, Assigned: mikepinkerton)

Tracking

({crash, regression})

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040511 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040511 Camino/0.7+

Camino crashes when trying to access a link in a web page.
Only Camino 0.7+ (1.8a Trunk Build) crashes.
Camino 0.8b (1.7 Branch Build) doesn't crash.

Reproducible: Always
Steps to Reproduce:
1) Go to http://www.mainichi-msn.co.jp/
2) Click any links

Actual Results:  
Camino crashes.

Expected Results:  
Open a link.
(Reporter)

Comment 1

15 years ago
Created attachment 148300 [details]
Camino.crash.log
(Assignee)

Comment 2

15 years ago
can you pinpoint on which day this regressed? that would help narrow down a
checkin window.

cc'ing roc in case there were any viewmanager changes
Keywords: crash, regression
(Reporter)

Comment 3

15 years ago
2004050508 (v0.7+) NB doesn't crash.
2004050608 (v0.7+) NB crashes.
So this problem has started from 20040506.

Updated

15 years ago
Severity: normal → critical
Summary: Crash when trying to access a link → Crash when trying to access a link [@ nsChildView::GetParent]
Eiichi does FireFox and /or Mozilla also crash on this page ?


(In reply to comment #2)
> can you pinpoint on which day this regressed? that would help narrow down a
> checkin window.
> 
> cc'ing roc in case there were any viewmanager changes

On those days roc checck the fix for
http://bugzilla.mozilla.org/show_bug.cgi?id=233441

(Reporter)

Comment 5

15 years ago
(In reply to comment #4)
> Eiichi does FireFox and /or Mozilla also crash on this page ?

Latest trunk build Firefox [ Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O;
en-US; rv:1.8a) Gecko/20040516 Firefox/0.8.0+] doesn't crash on this page.

Latest trunk build Camino [Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O;
en-US; rv:1.8a) Gecko/20040516 Camino/0.7+] still crashes.
(Reporter)

Comment 7

15 years ago
It seems to be fixed in 2004051808 (v0.7+) NB.
Could be related to http://bugzilla.mozilla.org/show_bug.cgi?id=242856#c67
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsChildView::GetParent]
You need to log in before you can comment on or make changes to this bug.