can't type into pop-up dialog boxes

RESOLVED DUPLICATE of bug 78928

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 78928
14 years ago
13 years ago

People

(Reporter: James Carlson, Unassigned)

Tracking

Trunk
x86
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.6) Gecko/20040116
Build Identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.6) Gecko/20040116

Typing into pop-up dialog boxes (such as the CTRL+F "Find" page) doesn't
work at all.  Clicking in the text box doesn't set the input focus there
and doesn't help.  I can copy text from another window using mouse button 2
into this text box, and I can highlight text using the mouse, and button 3
gives me a menu, and those features work.  But, still, the keyboard does *not*
work.

Typing from the keyboard works fine in the URL text area on the main browser,
and (obviously enough, since I'm able to file the bug) typing into textboxes
on web page forms works, but if I select "File->Open Web Location...", then I 
can't type into the pop-up dialog that appears.

An important clue might be that no cursor *ever* appears in a textbox in a
dialog window.

The exact same symptoms are seen on Thunderbird as well, so I suspect it's
a general issue (NSPR? GTK?), but I have no clue how to enable debugging to
track down the problem.  Hints on that would be appreciated.

If it makes any difference at all (I hope it doesn't ;-}), I'm using twm as
a window manager.


Reproducible: Always
Steps to Reproduce:
1.  CTRL+F
2.  Click in "Find text:" box
3.  Notice that no cursor appears
4.  Start typing anyway
5.  Observe that nothing happens

Actual Results:  
Nothing happens.

Expected Results:  
Letters typed should appear in the box

Default theme (I'm not sure I know _how_ to change themes).

Doesn't crash, so no stack trace.

Not related to any web page at all, so no particular test case.

Here's buildconfig:

about:buildconfig

Build platform
target
i386-pc-solaris2.10

Build tools
Compiler 	Version 	Compiler flags
cc 	Sun C 5.5 Patch 112761-04 2003/10/03 	-xO3 -xstrconst -xbuiltin=%all -mt
CC 	Sun C++ 5.5 Patch 113819-03 2003/10/14 	-xO3 -norunpath -mt

Configure arguments
--disable-tests --disable-debug --enable-optimize --without-system-nspr
--without-system-zlib --without-system-jpeg --without-system-png
--without-system-mng --enable-crypto --enable-js-ultrasparc --enable-extensions
--disable-xprint

Updated

14 years ago
OS: SunOS → Solaris

Comment 1

14 years ago
twm makes all the difference. This used to be in the release notes - hope it
hasn't vanished.. See info in bug 78928 for possible workarounds.

*** This bug has been marked as a duplicate of 78928 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.