If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Not all mail headers available in XUL/JS

RESOLVED DUPLICATE of bug 61523

Status

MailNews Core
MIME
--
minor
RESOLVED DUPLICATE of bug 61523
14 years ago
9 years ago

People

(Reporter: Andrew Taylor, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
The mailnews backend component responsible for providing mail headers to the
XUL/JS frontend (/mailnews/mime/emitters/src/nsMimeHtmlEmitter.cpp) doesn't
provide all the headers in a message.  It only provides a hardcoded list of
common headers.  This makes it difficult to customize the frontend to display
custom headers.

The code in question has this comment:

optimization: if we aren't in view all header view mode, we only show a small
set of the total # of headers.
don't waste time sending those out to the UI since the UI is going to ignore
them anyway.

How much difference does this optimization make?  The backend should either
reflect all the message headers.  If it actually impacts performance, it could
take a list of headers from the frontend to concentrate all the logic regarding
which headers should be displayed in the frontend.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 61523 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.