Closed Bug 243446 Opened 18 years ago Closed 18 years ago

URL bar loses focus if a tabbed page has a focus event

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 124750

People

(Reporter: phlegmatics, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

If I start to load a page that takes a while to load (for example hotmail.com),
and I CTRL+T for a new tab and start to type in the URL bar, and the first tab
has a focus event (for example "type username here"), then I lose focus in the
URL bar, and if I'm in the middle of typing, all the text will be typed in the
first tab that completed loading

Reproducible: Always
Steps to Reproduce:
1.load hotmail.com
2.quickly open a new tab and start typing in the URL until the hotmail tab
completes loading
3. the bar that you are currently typing in loses focus

Actual Results:  
lose focus of object that is currently being typed in (URL bar)

Expected Results:  
i should be able to finish typing the url and do whatever I want, but the focus
should be on the autofocus field once i move back to that tab

hotmail was an example, this happens with any page that might have an
onload="something.focus();"

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Assignee: bugs → nobody
QA Contact: tabbed.browser
You need to log in before you can comment on or make changes to this bug.