Help window shows error at bottom (but still works)

RESOLVED FIXED

Status

RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: jruderman, Assigned: rjkeller)

Tracking

({regression})

unspecified
regression
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Krueger said:

-----

This is minor, but still a bug. If you click on Help --> Help Contents you get
this screen:

http://www.lmhess.com/freebird/help.jpg

I see this in the Official 5/12 build and my own builds from 5/11 and 5/12. My
build from 5/08 works OK so this bug crept in somewhere between 5/09 and 5/11.

-----
(Reporter)

Updated

15 years ago
Summary: Help Contents is broken → Help window shows error at bottom (but still works)
(Assignee)

Comment 1

15 years ago
--> me (not sure how this got to ben).

I've heard that this has happened but cannot reproduce. I'll try creating a new
profile.
Assignee: bugs → rlk

Comment 2

15 years ago
Looks like fallout from Ben's massive comm.jar & friends removal in bug 243091,
if I'm not mistaken.  The removed stuff contained a few DTDs we reference from
the old toolkit (being fixed in bug 243116), and with those DTDs gone the errors
show up.
Depends on: 243116
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 3

15 years ago
Created attachment 148363 [details] [diff] [review]
Patch for Firefox Help Trunk

OK, bug fixed on the Firefox Help trunk. We'll probably have another Firefox
Help landing (much sooner than planned) to fix this and some other bugs.

I attached the patch that I just checked into the Firefox trunk that I'll port
over to Firefox ASAP.
(Assignee)

Comment 4

15 years ago
Fix checked into the Firefox trunk.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Entity isn't found with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a)
Gecko/20040515 Firefox/0.8.0+ and error still appears.

-> Reopen bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

15 years ago
Henrik: That problem is new and has nothing to do with the previous problem. I
checked in the fix for this early this morning. It was caused by a file that
wasn't checked in. I think it barely missed the nightly builds.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED

Updated

14 years ago
Component: Help Viewer → Help Viewer
Product: Firefox → Toolkit
Flags: in-testsuite?
Product: Toolkit → Seamonkey
You need to log in before you can comment on or make changes to this bug.