Message filters failing due to line wrap of headers

RESOLVED DUPLICATE of bug 124641

Status

RESOLVED DUPLICATE of bug 124641
15 years ago
12 years ago

People

(Reporter: gldisater, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.6) Gecko/20040512 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.6) Gecko/20040512 Firefox/0.8

If a filter is setup as follows:

List-ID contains <mailing-list@blah.com>

It will fail to match email with a List-ID that has <mailing-list@blah.com> line
wrapped to the subsequent line, as follows:

List-ID:  Really long description of what this list is for
         <mailing-list@blah.com>

Reproducible: Always
Steps to Reproduce:
1. Set up a filter to match
2. Fabricate an email that will cause target text to be line wrapped to the line
below the first line of the header field
3. Run the filter on the email

Actual Results:  
Filter will not take action

Expected Results:  
Filter should take action.

The Message filter "contains" appears to only check the line that the header
field label is on. It behaves like the following regex:

^List-ID.*search_text$
Comfirmed with Thunderbird 2004-05-12 build/Win-2K.
Same problem as Mozilla Mail&News Bug 124641 ?
> Bug 124641 Filter or Search: do not handle multi-line headers correctly
(Reporter)

Comment 3

15 years ago
(In reply to comment #2)
> Same problem as Mozilla Mail&News Bug 124641 ?
> > Bug 124641 Filter or Search: do not handle multi-line headers correctly

Yes, it would appear to be. The bug also manifests itself in broken mail threads
if the In-Reply-To: header is wrapped.

Comment 4

15 years ago
Confirmed with TB 0.8 on Win32
Scott, what should we do for common problem between Mozilla and Thunderbird?
To close as DUP of Mozilla Mail&News Bug 124641?
Or to keep open this bug and set depends on Bug 124641?

Comment 6

14 years ago
Ideally, dupe TB bugs which are in shared code.  Generally speaking, this means 
almost everything besides TB-specific front-end and TB-specific features.

*** This bug has been marked as a duplicate of 124641 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.