Closed Bug 243482 Opened 19 years ago Closed 19 years ago

Input type=file, no display of any 'browse...' button, widget not functional

Categories

(Firefox :: General, defect, P1)

PowerPC
macOS
defect

Tracking

()

RESOLVED FIXED
Firefox0.9

People

(Reporter: phiw2, Assigned: bugs)

References

()

Details

(Keywords: regression, Whiteboard: fixed-aviary1.0)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040512 Firefox/0.8.0+

Using [Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a)
Gecko/20040512 Firefox/0.8.0+]
Try to use the Validate by File Upload field in above mentioned form. On Firefox
(since 20040510 ?) the file upload filed  downs't display the text (expected
'browse...' ) on the button, and clicking the button doesn't do nothing.

Reproducible: Always
Steps to Reproduce:
1.Go to http://validator.w3.org/
2.try to upload file for validation, click on the button
3.nothing happens

Actual Results:  
The button should display some text ('browse...'), clicking on the button should
open a sheet to navigate to a file and allow the user to select a file on the
local file system.

Expected Results:  
display some text (label) on the button, and allow the user to upload a file
The red block points to the broken button.
Worksforme on Linux (build from May 12 as well)... any chance of narrowing down
the day this broke?
(In reply to comment #2)
> ... any chance of narrowing down
> the day this broke?

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040506
Firefox/0.8.0+

Works fine

But
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040510
Firefox/0.8.0+
is broken.
Are there any builds in that range you could check?  About 8000 lines of code
changed in those 5 days, in 3 dozen separate checkins or so.... :(
(In reply to comment #4)
> Are there any builds in that range you could check?  About 8000 lines of code
> changed in those 5 days, in 3 dozen separate checkins or so.... :(

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040508
Firefox/0.8.0+

Works fine. Apparently no OS X builds on 0509.

Is this a problem in SeaMonkey builds?  Or just Firefox?

I don't see any changes to core gecko code that woul really affect this, and
there was a whole slew of major changes to Firefox (eg bug 243091 looks pretty
suspicious to me...)
[update] It is not only the input type=file. Any submit button breaks. 

I just attempted to update my blog. No way to submit a post (input type=submit).
Or changing the display of the comments on http://www.macosxhints.com/ from
threaded to anything else (a submit button with a POST attached) doesn't work
either.
(In reply to comment #6)
> Is this a problem in SeaMonkey builds?  Or just Firefox?
> 

I'm testing with Firefox (OS X) here. (and using Mozilla 1.7 RC1 to submit to
bugzilla).

(In reply to comment #8)
> I'm testing with Firefox (OS X) here. (and using Mozilla 1.7 RC1 to submit to
> bugzilla).

Yes, I realize that... ;)  Could you try a May 11 or later SeaMonkey nightly?

Note that I just tried a Linux firefox nightly (from May 12) and the browse
button appears there...
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040512

Works fine

OK, then this is firefox-specific.  Reassigning accordingly.

Upping severity, since this is pretty basic functionality to have broken...
Assignee: nobody → firefox
Severity: normal → major
Component: Layout: Form Controls → General
Keywords: regression
Product: Browser → Firefox
QA Contact: core.layout.form-controls
Version: Trunk → unspecified
Ben, see comment 6.  This looks like Firefox-only and Mac-only....
Flags: blocking0.9?
Severity: major → critical
Works fine on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a)
Gecko/20040512 Firefox/0.8.0+
*** Bug 243884 has been marked as a duplicate of this bug. ***
any progress here?
Assignee: firefox → bugs
Flags: blocking0.9? → blocking0.9+
Attached patch patchSplinter Review
layout should not depend on communicator for this file
Hm, I don't see this on the branch, but I can understand why it might have
broken (see patch). I haven't tested this yet. Am pulling a trunk tree now on my
mac to test. 

In general nothing in gecko should depend on resources in communicator
especially... I'm slightly uncomfortable about making them depend on global too
but that seems to be fairly widespread. I think a tree-wide patch to create a
"gecko" resources package would be a good idea. 
Status: NEW → ASSIGNED
Ignore the patch. This was fixed by reordering the makefiles so that
communicator resources are packaged before the .app file is rsync'ed. I'll file
a bug at some future point about repackaging all gecko resources into its own
chrome registry bundle, rather than relying on obsolete seamonkey terminology. 
Fixed, branch and trunk. 
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Priority: -- → P1
Resolution: --- → FIXED
Target Milestone: --- → Firefox0.9
Whiteboard: fixed-aviary1.0
You need to log in before you can comment on or make changes to this bug.