If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

escaped characters on [File] > [Save Page As] cause problems with ed2k links

RESOLVED DUPLICATE of bug 150376

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 150376
14 years ago
9 years ago

People

(Reporter: marinebane, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

If a webpage containing an ed2k link is saved, the | (pipes) in the ed2k link
are escaped to %7C . so a link like this (that works originally):
ed2k://|file|Knoppix.3.4.Cebit.2004.Edition.cue|94|9763B401E202F6DE43CE8FDCB4AD7777|/

becomes (when you save as a file):
ed2k://%7Cfile%7CKnoppix.3.4.Cebit.2004.Edition.cue%7C94%7C9763B401E202F6DE43CE8FDCB4AD7777%7C/

which does not work when you click it.

although this may not be a bug in that FireFox is probably handling the escaping
of url's properly, it either should make an exception for | (pipes) in urls, or
it should be fixed so that even though it is escaped in the source, it sends the
unescaped version to explorer.

Reproducible: Always
Steps to Reproduce:
1. Find a page that has ed2k links on it, such as here: 
2. File > Save Page As... and save it as a file
3. Open the file, and try to run the link if you have an ed2k client, otherwise
look at the source of the file.
Actual Results:  
the ed2k link failed.
the source contained an escaped ed2k link

Expected Results:  
either unescape the ed2k link before running it, or not escaping it in the first
place.

Updated

14 years ago
Assignee: firefox → bugs
Component: Menus → Download Manager
QA Contact: bugzilla → aebrahim
This bug was last touched before 1.0.4. Is it still reproducable?
Try the latest branch build (1.0.5): http://www.mozilla.org/products/firefox/
Try the latest nightly trunk build (v1.0+): http://www.mozilla.org/developer
(Reviving old UNCONFs)

Comment 2

12 years ago
This bug is still reproducable with both the latest nightly and 1.0.5.

Note: This bug only occurs when the page is saved as a 'Webpage, Complete.' The
bug does not occur when saving as 'Webpage, HTML only.' I presume that during
the rewriting of the page (when resource/image locations are modified), it
escapes the pipes in the URLs.

Comment 3

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060920 BonEcho/2.0

I can reproduce this.  However, I suspect the problem is that FF does not save the website as downloaded, but as it stores it in memory, having built the DOM tree and so on (see a number of other bugs on this topic).  I suspect the basic problem is that the pipe character is simply not allowed in URLs, so FF encodes it (which is what is supposed to be done for non-valid characters).  I therefore suspect the bug is invalid or wontfix.  But I think it is a developer call.

*** This bug has been marked as a duplicate of 150376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.