Javascript is _always_ able to deactivate menu bar (including tab display)

RESOLVED DUPLICATE of bug 152256

Status

--
enhancement
RESOLVED DUPLICATE of bug 152256
15 years ago
11 years ago

People

(Reporter: c-otto, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040425 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040425 Firefox/0.8

Hello!

I set up Mozilla to not allow javascripts to change any window setting (size,
status bar, ...). There is no option to block JS to hide the menubar (including
tab display). That is very annoying. Whenever you load a page including the
following line in a new tab instead of a new window you have no menu bar and
have to navigate "blind".

<body bgcolor="#FFFFFF"
onLoad="window.toolbar.visible=false,window.menubar.visible=false,window.directories.visible=false,window.locationbar.visible=false">

This line is nothing special compared to window resizing and such.
Please add blocking of that menubar hide.
Thanks!

Reproducible: Always
Steps to Reproduce:
1. Switch off everything JS is able to do
2. Load a page with above line _in a new tab_
3. lose your menubar and tab display



Expected Results:  
There should be an option to disable hiding the menubar and tab display.
There is most certainly a preference for this.  Lack of UI exposing the
preference is a separate issue.

In any case, anything that affects the browser window is probably not a JS
engine bug (rather a DOM or layout bug).
Assignee: general → guifeatures
Component: JavaScript Engine → XP Apps: GUI Features
QA Contact: pschwartau

Comment 2

15 years ago
using attatchemnt 87901 from bug 152256 WFM LInux 2004062405
yeah, that bug seems to have fixed this. marking dup.

*** This bug has been marked as a duplicate of 152256 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite

Updated

11 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.