Download manager should display even if a download is very fast when "close download manager when all downloads complete" option is not checked.

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
--
enhancement
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Eric, Unassigned)

Tracking

Trunk
mozilla1.9alpha6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040513 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040513 Firefox/0.8

When I download a file, even if it downloads very quickly (in fact especially
then) I usually want to do something with it immediately (such as launch it). 
The fact that the Download Manager does not appear after a quick download forces
me to browse to the file manually.  This behavior is highly irritating.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.



Expected Results:  
When "close download manager when all downloads complete" option is not checked,
the download manager should still display after a quick download.

Comment 1

14 years ago
Does anyone know the reason for the current behavior of not showing the download
manager for fast downloads?
(In reply to comment #1)
> Does anyone know the reason for the current behavior of not showing the download
> manager for fast downloads?

If the current behavior didn't exist, simply right-clicking on a fully-displayed
image stored in the browser cache and saving it would result in the popup being
displayed -- hardly ideal.  There might have been other reasons in addition to
this one, but I can't remember them.

Comment 3

14 years ago
If that's the only reason, it would make more sense to special-case the "Save
Image" context menu command than to special-case fast downloads.

Comment 4

14 years ago
*** Bug 243582 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
I'm not sure if this description is accurate.  It seems to me that the download
manager only fails to display if you haven't selected a save location by the
time the download completes.  I find this problematic in any case.

Comment 6

14 years ago
I'm duping this against the newer bug, because that has a better summary. There
was a decision made not to pop up the download manager for fast downloads.(In
reply to comment #3)
> If that's the only reason, it would make more sense to special-case the "Save
> Image" context menu command than to special-case fast downloads.

This is now bug 250459.

As for the original bug, I'm not sure that its valid. I'm pretty sure that Ben
Goodger decided that the download manager should now show for fast downloads,
although right now I can't find the documentation for that...

Jesse do you know anything about it?
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041017 Firefox/1.0

I tried this with numerous fast downloads, but the manager popsup every time.
browser.download.manager.openDelay 0 fixed this ?

please set new or wfm

Comment 8

13 years ago
This is an irritating problem when you have a high speed connection.  It also
occurs if the file is downloaded in the background before you have told firefox
where to save the file.

Comment 9

13 years ago
This is an irritating problem when you have a high speed connection.  It also
occurs if the file is downloaded in the background before you have told firefox
where to save the file.

Comment 10

11 years ago
Isn't this bug fixed?  It seems to work for me in Firefox 1.5.0.x, any platform.

Updated

11 years ago
QA Contact: ali → download.manager
Assignee: bugs → nobody

Updated

11 years ago
Assignee: nobody → sdwilsh
Flags: blocking-firefox3?
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Firefox 3 alpha6
Version: unspecified → Trunk

Updated

11 years ago
Assignee: sdwilsh → nobody
Actually, this WFM, and I see no reason why the code wouldn't show it.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Flags: blocking-firefox3?
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.