IMAP IDLE support causes hang and delete entire Mozilla Profile(s)

RESOLVED FIXED

Status

MailNews Core
Networking: IMAP
--
critical
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: Mark Knipfer, Assigned: Bienvenu)

Tracking

({fixed1.7})

Trunk
x86
Windows XP
fixed1.7
Bug Flags:
blocking1.7 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-aviary1.0)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040421

Tonight I lost my entire Mozilla 1.7 RC1 profile in Windows XP and Mac OS X
10.3.3.  The symptom is where you exit Mozilla 1.7 RC1 and it hangs in memory
for a while.  This deleted the \Profile and onward path.

In Windows XP you have to open the Windows XP Task Manager, click on Processes,
highlight mozilla.exe and click End Process.

In Mac OS X 10.3.3 you right-click on the Mozilla icon on the Dock, wait a few
seconds for the pop-up menu to display and click Forced Quit.

If Mozilla 1.7 RC1 continues to hang where it will not completely exit from
memory (or stop running), this completely deletes the Mozilla profile; if more
than one profile, it will remove all profiles.

I could not find any corrupted files that I checked; the address book, message
filters, message files, I deleted all *.msf files and built them back by
clicking on each mail folder, etc.

I stumbled on this problem/bug recently, but I thought I had done something
wrong or something was running on the system that caused it to occur.  Now I see
the symptom that makes an entire Mozilla profile to delete. 

Update....

In Mozilla 1.7 RC1 click Edit | Mail and Newsgroups Account Settings, click on
Server Settings, click Advanced, in the IMAP tab unselect 'Use IDLE command if
the server supports it'.  Click OK and OK to return to Mozilla Mail.

Mozilla 1.7 RC1 Mail no longer hangs on exit where it deletes the Profile
directory, so far.

Mozilla 1.7 RC1
Windows XP SP1a (all updates installed)
Mac OS X 10.3.3 (all updates installed)
E-mail account type: IMAP
E-mail server type: Linux, IMAP4 


Reproducible: Sometimes
Steps to Reproduce:
1. Run Mozilla Mail using an IMAP account.
2. Make sure the IDLE support has been enabled the Advanced Account Settings window.
3. Quit Mozilla and when it hangs, let it hang for a while and then when you run
Mozilla again, the entire Mozilla profile has been deleted.


Actual Results:  
The Mozilla Profile(s) had been deleted.

Expected Results:  
Just in Mozilla 1.7 RC1 where IMAP IDLE support is a new feature.
(Assignee)

Comment 1

14 years ago
these are two separate bugs - idle hanging on exit is one, and starting up
mozilla with an existing instance of mozilla running erasing your profile is a
different bug. I thought the latter bug had been fixed a long time ago, but
apparently not. Cc'ing ccarlen.

What kind of imap server are you using?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> these are two separate bugs - idle hanging on exit is one, and starting up
> mozilla with an existing instance of mozilla running erasing your profile is a
> different bug. I thought the latter bug had been fixed a long time ago, but
> apparently not. Cc'ing ccarlen.
> 
> What kind of imap server are you using?

To my knowledge, the IMAP server is running on Linux and its IMAP Rev 4.
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> To my knowledge, the IMAP server is running on Linux and its IMAP Rev 4.

Here is a little more information:

RedHat RPM imap-2001a-1.71.0

I believe this is the University of Washington version.
(Assignee)

Comment 4

14 years ago
Created attachment 148665 [details] [diff] [review]
proposed fix

make ending idle behave like close and logout at shutdown, don't wait.
(Assignee)

Updated

14 years ago
Attachment #148665 - Flags: superreview?(mscott)

Updated

14 years ago
Attachment #148665 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 5

14 years ago
fixed (for hang on exit at least - profile deleting is a different problem)
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Whiteboard: fixed-aviary1.0
(Assignee)

Comment 6

14 years ago
this might be useful on 1.7 as well...see last few comments in
http://bugzilla.mozilla.org/show_bug.cgi?id=67894

Flags: blocking1.7?

Comment 7

14 years ago
Comment on attachment 148665 [details] [diff] [review]
proposed fix

a=asa (on behalf of drivers) for checkin to 1.7
Attachment #148665 - Flags: approval1.7+
(Assignee)

Updated

14 years ago
Keywords: fixed1.7

Updated

14 years ago
Flags: blocking1.7? → blocking1.7+
(Assignee)

Comment 8

14 years ago
*** Bug 67894 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.