nachtzugreise.de/nachtzugreisen.de - Bad example: Booking process won't start (higher browser version required)

RESOLVED FIXED

Status

Tech Evangelism Graveyard
German
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: eduardosoriajimenez, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

It says i need a higher version, IE won´t do either although i have IE 6.
	Für den Buchungsvorgang benötigen Sie eine neuere Browserversion
(Internet Explorer 4.x und neuere / Netscape 4.x und neuer)

  	Sie können sich kostenfrei Updates unter den folgenden Links downloaden:

	 Internet Explorer Upgrade
	 Netscape Upgrade


Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
If it doesn't work in any browser, then how is it a Mozilla bug?  What's the bug?

It seems to me that the site would be just flat broken, if that's the case.

Comment 2

14 years ago
I had some fun with the Javascript console, see a selection of messages:


Warning: useless expression
Source File: http://www.nachtzugreise.de/DBautozug/_includes/scripts.js
Line: 163

	void(null);


Client detection is looking for IE4, NS4, NS5, NS6:

Warning: reference to undefined property document.layers
Source File: http://www.nachtzugreise.de/DBautozug/_includes/scripts.js
Line: 90




Warning: reference to undefined property plugin.SetWindow

Source File: javascript: function jsScriptObject(obj) { this.wrappedJSObject =
obj; } jsScriptObject.prototype = { evaluate : function(expression) { return new
jsScriptObject(eval(expression)); } }; var plugin =
document.embeds['nav_flash_home']; plugin.SetWindow(new
jsScriptObject(window),1147723150);
Line: 1




Error: plugin.SetWindow is not a function

Source File: javascript: function jsScriptObject(obj) { this.wrappedJSObject =
obj; } jsScriptObject.prototype = { evaluate : function(expression) { return new
jsScriptObject(eval(expression)); } }; var plugin =
document.embeds['nav_flash_home']; plugin.SetWindow(new
jsScriptObject(window),1147723150);
Line: 1


Error: body_onload is not defined


Warning: reference to undefined property document.embeds.nav_flash_home

Source File: javascript: function jsScriptObject(obj) { this.wrappedJSObject =
obj; } jsScriptObject.prototype = { evaluate : function(expression) { return new
jsScriptObject(eval(expression)); } }; var plugin =
document.embeds['nav_flash_home']; plugin.SetWindow(new
jsScriptObject(window),1147723150);
Line: 1


Error: plugin has no properties
Source File: javascript: function jsScriptObject(obj) { this.wrappedJSObject =
obj; } jsScriptObject.prototype = { evaluate : function(expression) { return new
jsScriptObject(eval(expression)); } }; var plugin =
document.embeds['nav_flash_home']; plugin.SetWindow(new
jsScriptObject(window),1147723150);
Line: 1

Comment 3

14 years ago
First of all, I think this is Tech-Evang/German.

The site uses browser sniffing and identifies only Netscape and IE. Interesting
is, if I first visit the main index page at http://www.nachtzugreise.de/ it
works with MSIE and NS 7.1 (or a masked Mozilla as NS 7.1). The page redirects
at the end to the reporter's URL. The booking works and no asking for upgrading.
STRANGE.

Web sniffer reveals

for the main URL
http://web-sniffer.net/?url=http%3A%2F%2Fwww.nachtzugreise.de%2F&submit=Submit&gzip=yes&type=GET

if you have JS, Cookies on and use Netscape (result for IE is the same) you will
open then
http://web-sniffer.net/?url=http%3A%2F%2Fwww.nachtzugreise.de%2Fautozug%2Findex.asp%3FJ%3DY%26C%3DY%26DA%3DN&submit=Submit&gzip=yes&type=GET
which leads to a Http 302 and the reporter's URL.

I don't know why it works only (for NS 7.1/IE) if you access the site through
the index page. 
(Reporter)

Comment 4

14 years ago
hi,

>The site uses browser sniffing and identifies only Netscape and IE. Interesting
>is, if I first visit the main index page at http://www.nachtzugreise.de/ it
>works with MSIE and NS 7.1 (or a masked Mozilla as NS 7.1). The page redirects
>at the end to the reporter's URL. The booking works and no asking for upgrading.
>STRANGE.

going through the index site doesn´t work for me. i use mozilla 1.6. what do i
have to do to mask mozilla as NS 7.1?
thanks in advance


>From: bugzilla-daemon@mozilla.org
>To: eduardosoriajimenez@hotmail.com
>Subject: [Bug 243633] Bad example: Booking process won´t start (higher browser
version required)
>Date: Wed, 19 May 2004 08:19:28 -0700
>
>http://bugzilla.mozilla.org/show_bug.cgi?id=243633
>
>
>
>
>
>------- Additional Comments From ostgote@gmx.net  2004-05-19 08:19 PDT -------
>First of all, I think this is Tech-Evang/German.
>
>The site uses browser sniffing and identifies only Netscape and IE. Interesting
>is, if I first visit the main index page at http://www.nachtzugreise.de/ it
>works with MSIE and NS 7.1 (or a masked Mozilla as NS 7.1). The page redirects
>at the end to the reporter's URL. The booking works and no asking for upgrading.
>STRANGE.
>
>Web sniffer reveals
>
>for the main URL
>http://web-sniffer.net/?url=http%3A%2F%2Fwww.nachtzugreise.de%2F&submit=Submit&gzip=yes&type=GET
>
>if you have JS, Cookies on and use Netscape (result for IE is the same) you will
>open then
>http://web-sniffer.net/?url=http%3A%2F%2Fwww.nachtzugreise.de%2Fautozug%2Findex.asp%3FJ%3DY%26C%3DY%26DA%3DN&submit=Submit&gzip=yes&type=GET
>which leads to a Http 302 and the reporter's URL.
>
>I don't know why it works only (for NS 7.1/IE) if you access the site through
>the index page.
>
>
>--
>Configure bugmail: http://bugzilla.mozilla.org/userprefs.cgi?tab=email
(Reporter)

Comment 5

14 years ago
hi,

>The site uses browser sniffing and identifies only Netscape and IE. Interesting
>is, if I first visit the main index page at http://www.nachtzugreise.de/ it
>works with MSIE and NS 7.1 (or a masked Mozilla as NS 7.1). The page redirects
>at the end to the reporter's URL. The booking works and no asking for upgrading.
>STRANGE.

going through the index site doesn´t work for me. i use mozilla 1.6. what do i
have to do to mask mozilla as NS 7.1?
thanks in advance


>From: bugzilla-daemon@mozilla.org
>To: eduardosoriajimenez@hotmail.com
>Subject: [Bug 243633] Bad example: Booking process won´t start (higher browser
version required)
>Date: Wed, 19 May 2004 08:19:28 -0700
>
>http://bugzilla.mozilla.org/show_bug.cgi?id=243633
>
>
>
>
>
>------- Additional Comments From ostgote@gmx.net  2004-05-19 08:19 PDT -------
>First of all, I think this is Tech-Evang/German.
>
>The site uses browser sniffing and identifies only Netscape and IE. Interesting
>is, if I first visit the main index page at http://www.nachtzugreise.de/ it
>works with MSIE and NS 7.1 (or a masked Mozilla as NS 7.1). The page redirects
>at the end to the reporter's URL. The booking works and no asking for upgrading.
>STRANGE.
>
>Web sniffer reveals
>
>for the main URL
>http://web-sniffer.net/?url=http%3A%2F%2Fwww.nachtzugreise.de%2F&submit=Submit&gzip=yes&type=GET
>
>if you have JS, Cookies on and use Netscape (result for IE is the same) you will
>open then
>http://web-sniffer.net/?url=http%3A%2F%2Fwww.nachtzugreise.de%2Fautozug%2Findex.asp%3FJ%3DY%26C%3DY%26DA%3DN&submit=Submit&gzip=yes&type=GET
>which leads to a Http 302 and the reporter's URL.
>
>I don't know why it works only (for NS 7.1/IE) if you access the site through
>the index page.
>
>
>--
>Configure bugmail: http://bugzilla.mozilla.org/userprefs.cgi?tab=email

Comment 6

14 years ago
Please change the Product/Component of this bug to Tech-Evang/German.

(In reply to comment #5)
> going through the index site doesn´t work for me. i use mozilla 1.6. what do i
> have to do to mask mozilla as NS 7.1?
> thanks in advance

Open about:config and change/add the following prefs:

general.useragent.vendor to Netscape
general.useragent.vendorSub to 7.1

Both are string prefs.

Comment 7

14 years ago
Reporter, PLEASE change the Product/Component of this bug to Tech-Evang/German
and include the site's name in the summary (nachtzugreise.de).

contacts:
http://www.nachtzugreise.de/DBautozug/kontakt.html
http://www.nachtzugreise.de/DBautozug/impressum.html

I wrote the webmaster about this bug through the web contact form. 

Comment 8

14 years ago
I got an answer from the customer support.

---- original answer (German):

Sehr geehrter Herr xxx,

vielen Dank für Ihren Hinweis.

Die Online-Buchung bei www.nachtzugreise.de ist ein Modul welches
ursprünglich mit speziell auf Netscape und Internet Explorer optimierten
Methoden implementiert wurde.
Es sind in diesem Teil komplexe JavaScript-Elemente verwendet worden,
die beispielsweise unter Mozilla unerwünschte Effekte hervorrufen. Daher
war es nötig nur Browser zuzulassen, die 100%ig funktionieren.
Der Grund für die Verwendung dieser Funktionalitäten ist, dass es zunächst
nur auf diesem Wege möglich war, einen Buchungsprozess zu schaffen, der
den Kunden möglichst komfortabel führt.
Uns ist bewusst, dass Browser-Restriktionen jeglicher Art problematisch und
unbefriedigend sind und schalten diese, soweit es mit vertretbarem Aufwand
möglich ist, schnellstmöglich ab.

Mit freundlichen Grüßen

T. R.
DB AutoZug GmbH

-------------- roughly translation:

We know it, it is because of some of the used JS (optimized for IE and NS) has
lead to problems with Mozilla. Only so we can guarantee a convenient booking
process. We know such a restriction is problematic, but we will see if we can
drop it soon (if the work is justifiable).

Comment 9

14 years ago
I got a second answer from the support. They announce the support of
Mozilla/Firefox! I tested it with FF 0.9 and Mozilla 1.7, it works!

So someone (Reporter, someone with permissions) could do:

- change the Product/Component of this bug to Tech-Evang/German
- include the site's name in the summary (nachtzugreise.de)
- resolve the bug as fixed

Thanks.

Updated

13 years ago
Assignee: general → german
Component: Browser-General → German
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
QA Contact: general → german
Hardware: PC → All
Summary: Bad example: Booking process won´t start (higher browser version required) → nachtzugreise.de - Bad example: Booking process won´t start (higher browser version required)
Version: Trunk → unspecified

Comment 10

13 years ago
Tested with Mozilla 1.8a5 and FF 0.12/1.0rc2. It works now as I said. Resolving.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Summary: nachtzugreise.de - Bad example: Booking process won´t start (higher browser version required) → nachtzugreise.de/nachtzugreisen.de - Bad example: Booking process won't start (higher browser version required)
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.