Linux Installer Crash on Change Installation Directory

VERIFIED DUPLICATE of bug 257826

Status

()

Firefox
Installer
P2
critical
VERIFIED DUPLICATE of bug 257826
14 years ago
12 years ago

People

(Reporter: Ali Ebrahim, Assigned: Brian Ryner (not reading))

Tracking

({crash, stackwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Build:
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2004-05-14-15-trunk/firefox-i686-linux-gtk2+xft-installer.tar.gz

Steps to reproduce crash:
1. Untar installer (I did to /home/aebrahim/firefox-installer/)
2. cd /home/aebrahim/firefox-installer/
3. ./firefox-installer
4. Press Forward on Welcome screen
5. Accept EULA
6. Select Custom (don't change default install directory)
7. Press Forward
8. Select all options
9. Press Forward
10. Press Back
11. Press Back
12. Press Change
13. I changed directory from firefox-installer to firefox-test
14. Press OK
15. Press Forward
16. Asks if you want to create directory. Say Yes.

Actual results:
./firefox-installer: line 56: 27133 Segmentation fault      ./${BINNAME}-bin $@

Expected results:
Obvious...

Am using a Fedora Core 1 install with all updates applied, using stock kernel.

Updated

14 years ago
Keywords: stackwanted

Comment 1

14 years ago
This happened for me on Red Hat Workstation as well, the first time I tried to
install.  The second attempt worked fine.  (... so reproducing this might be
easier if you try to change to a directory that doesn't exist, so that the
installer has to create it?)

Backtrace:

#0  0x0804c9ec in nsSetupType::GetComponents (this=0x0) at nsSetupType.cpp:115
#1  0x0804f9ec in nsSetupTypeDlg::DSRequired () at nsSetupTypeDlg.cpp:907
#2  0x06d9c810 in ?? ()
(gdb)

Comment 2

14 years ago
Oh, and the version I duplicated this with is the installer from
firefox/releases/0.9/ ...

Comment 3

14 years ago
Build: 
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/0.9.1/firefox-0.9.1-i686-linux-gtk2+xft-installer.tar.gz

Steps to reproduce crash:
Same as above

Actual results:
none

I am using Fedora Core 2 install (kernel 2.6.6-1.435 #1 Mon Jun 14 09:09:07 EDT
2004 i686 i686 i386 GNU/Linux) 

not sure if this would be the same bug, but I can easily crash the Linux
installer by using the Back/Forward buttons. tested with 2004-07-12-11-0.9 on
fedora core 2.

1. ./firefox-installer
2. accept EULA
3. select Custom installation (and optionally change directory), click Forward
4. in the next panel (selecting additional packages; optional to change stuff
there), click Back
5. click Forward

results: the installer crashes, with the following error in the console

./firefox-installer: line 56:  2450 Segmentation fault      ./${BINNAME}-bin $@

(alas, no stack trace.)
Flags: blocking-aviary1.0?

Updated

14 years ago
Flags: blocking-aviary1.0? → blocking-aviary1.0+
Priority: -- → P2
Assignee: bugs → bryner

Comment 5

14 years ago
The installer also crashes on RedHat 9

Comment 6

14 years ago
dupe of "using "back" in installer during custom install = reproducable crash"

*** This bug has been marked as a duplicate of 257826 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Flags: blocking-aviary1.0+
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

12 years ago
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.