Thunderbird freezes / crashes after inactivity

RESOLVED WORKSFORME

Status

defect
--
critical
RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: fago, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Build Identifier: Thunderbird version 0.6 (20040502)

After a period of inactivity (several hours) Thunderbird becomes completely
unresponsive -- the program window does not even get redrawn -- forcing a manual
kill.

This is completely reproducable for me with v0.6, while v0.5 did not have this
behavior.

Reproducible: Always
Steps to Reproduce:
Open Thunderbird and wait.

Actual Results:  
Freeze requiring kill.

Expected Results:  
Nothing.

I would like to help track this down.

Comment 1

15 years ago
*** Bug 243700 has been marked as a duplicate of this bug. ***
Reporter

Comment 2

15 years ago
This bug causes dataloss in some cases.

After returning from a period of inactivity, in some cases Thunderbird appears
to be responsive. So I compose an email -- only to have Thunderbird hang upon
pressing "send."


How can I dump a long or some such to help track this down?


PS: Sorry for the dupe.
Assignee

Comment 3

15 years ago
can anyone try a trunk nightly to see if this problem still exists there?

Comment 4

15 years ago
I also have the same bug in Mac OSX. After computer sleep and rewake or unactivity it hangs. I never 
had this in previous versions, only 0.6

Comment 5

15 years ago
I find this on Mac OS X 10.3 with a Thunderbird 0.7.1 20040702 nightly, and I've
noticed it since 0.7.0. It seems to occur after a variable amount of time,
anything from ten minutes upwards. The symptoms are much as those reported
originally; I get the OS X 'beachball' busy cursor, OS X decides the program
isn't responding, and it has to be killed. I haven't tried a trunk build yet,
but I may later today.

Comment 6

14 years ago
Think it is related: my windows build tends to consume 99% cpu load after a
period of time. Only checked mail and send one.
Will try to reproduce and look if it is allocating more memory/gdi object etc.

Comment 7

14 years ago
This might be related.

I don't use the nightlies, but this has been going on at least since 1.0.  I'm
on Windows XP.

I've never had the crash, but Thunderbird is horribly slow to do anything (view
a message, write a message, change folder, pull up a menu, anything) after a
long time of inactivity.  At it's worst, over a minute before anyhting works the
way it should.

At first I thought it was just after the screen saver had been in use, but it
happens if Thunderbird has been sitting in the background while I'm doing other
stuff.  I don't minimize, if that's relevant.  I can't figure out what the time
threshold is before this starts happening.

Comment 8

14 years ago
It's a big show-stopper at the moment.
My boss went back to OE because of this.

Ways to reproduce:
Keep Thunderbird open all day with (multiple?) IMAP accounts (I have 2 IMAP
servers).

At the end of the day my CPU load is all consumed by Thunderbird (99% cpu load).
GDI objects are not climbing (much) and steady at 270 objects.
Memory usage is around 35.268K (not rising).
A "netstat -a -n -o" in dos-box shows me 9 IMAP ESTABLISHED connections and 1
CLOSE WAIT connection to my IMAP servers.

No Javascript errors are warnings are show ATM.

I hope this bug gets fixed soon, will be glad to perform other additional tests
on request.

My build is  WinXP (20050418)

Comment 9

14 years ago
could this be related to bug #293568 maybe?

Comment 10

14 years ago
What kind of imap server are you using? If it's a courier server, have you tried
setting the max number of connections to 4, in the advanced imap server settings?

Comment 11

14 years ago
BTW: related to bug #292041?

Comment 12

14 years ago
I experience the same problem with Thunderbird version 1.0.6 (20050716).  I am 
forced to close the application and wait for it to unload.  Upon restart of 
the program, it seems to work.  It occurs with an inactivity period of a 
couple of hours.  My operating system is Windows xp professional.  my email 
account is lventre@cox.net

Comment 13

14 years ago
I get this too, have had it ever since I started using 1.5a1.

After a while Thunderbird just hangs.

I've got 2 IMAP accounts, one connects to a Surgemail server (www.surgemail.com)
and the other to Courier IMAP.

I don't have this problem on another machine running 1.07

It is still happening in 1.5b2.

Comment 14

14 years ago
Still happening in 1.5rc1 on my WinXP machine... also installed on my Apple Powerbook, and it now happens there too. Also know someone else who's having the same issue on a Powerbook.

Comment 15

14 years ago
I can confirm this with 1.5RC1 under Windows XP SP2. After a period of inactivity of no more than 1 hour I have to force-kill Thunderbird.

Running IMAP/SSL with approximately 12 subscribed folders.

Comment 16

14 years ago
This bug has been a major PITA ever since I started using TB 1.5b1, and it hasn't gotten better with 1.5rc1 or the 1.5rc2 test build (20051201), and in my case I suspect it's IMAP related. I'm using Cyrus IMAP via SSL, on WinXP.

Typically I see this bug when the computer is waking up from standby mode. Sometimes TB will wake up right away, but sometimes the window won't even get redrawn for 5-10 minutes, and often it won't get redrawn at all, so that I have to use the task manager to kill TB. This freezing-up happens almost daily.

Possibly related: TB just now froze up on me when it was trying to auto-save a draft during compose. Just by chance, I had momentarily lost my Internet connection (ADSL), and TB tried to auto-save the draft during this time. Apparently due to the lack of IMAP connection, TB completely froze up: the status bar says "copying message to Saved folder" (Saved = my Drafts), the cursor is frozen into hour-glass mode in the compose window, and if I try to switch back to the main TB window it doesn't get redrawn at all. I waited about 20 minutes just to see if TB would snap out of its petrified state, but no luck.
This doesn't appear to be a problem under 1.5 RC1 or 1.5 RC2 when using Dovecot as the IMAP4 server.  I've been using RC1 here since it was released, with no problems.

Comment 18

14 years ago
Just had 'this' occur to me.
At the time, it seemed to be updating the various MSF files for the local copy of the folders held on the IMAP server. The file-sizes were changing by a few bytes, nothing more. Maybe garbage collection of some sort?
I'm using 1.5. I have only a single account (IMAP) set, and a bunch of local folders held elsewhere. Close and restart Thunderbird, and all is well.

Comment 19

14 years ago
I've had this happen a lot - when I break into the debugger, nothing interesting is going on.

Comment 20

14 years ago
I'm experiencing the same problem after only a few minutes. I've got several IMAP accounts on the same Courier IMAP server, plus a couple of POP accounts.

The Courier IMAP server accepts up to 32 connections. Thunderbird 1.07 worked reasonably well, although it did see this problem from time to time. In particular when connected to the Internet over dialup.

Ever since switching to Thunderbird 1.5 the problem has gotten so bad that I'll have to downgrade to 1.07.

Comment 21

13 years ago
I'm seeing this as well.  I'm running TB version 1.0.7 (20050923) on WinXP.

Typically, I'll hibernate my laptop when leaving work, open it later in the evening, hibernate it again, etc.  This works fine for a while, but eventually TB will start eating the CPU.  Also -- and this is probably important -- TB is doing a ridiculous number of "other I/O" (tens or hundreds of thousands per second, with the total count in the hundreds of millions).

I've also seen this sort of behavior with Firefox.

Comment 22

13 years ago
I have been running version 2 beta 1 for 24 hours without any problem. In particular it seems that this bug has disappeared.
Daniel Lidar in comment #22
> I have been running version 2 beta 1 for 24 hours without any problem. In
> particular it seems that this bug has disappeared.

Daniel, you saw this bug in which release?

Comment 24

13 years ago
(In reply to comment #23)
> Daniel Lidar in comment #22
> > I have been running version 2 beta 1 for 24 hours without any problem. In
> > particular it seems that this bug has disappeared.
> Daniel, you saw this bug in which release?

1.5.0.9 on a Centrino Duo @ 2.33GHz with 3MB RAM running Windows XP. Note the (for me) related https://bugzilla.mozilla.org/show_bug.cgi?id=364795.

Updated

13 years ago
Blocks: 352352
QA Contact: general
anyone still see this in linux thunderbird v2 or trunk?
closing WFM per comment 22
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 0.9

Updated

11 years ago
No longer blocks: 352352
You need to log in before you can comment on or make changes to this bug.