Closed Bug 243704 Opened 16 years ago Closed 16 years ago

Ability to drag and drop files into <input type="file"> as an alternative to "Browse..."

Categories

(Core :: DOM: Drag & Drop, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 50660

People

(Reporter: T.J.Hunt, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

If you have already located the file you wish to upload (using the OS's GUI),
then it is quite annoying to have to click on the Brose... of a <input
type="file"> form element and find it again. 

It would be much easier (and quite cool) if you could just drag and drop the
file over the file upload control and have the file name filled in for you.


Reproducible: Always
Steps to Reproduce:

*** This bug has been marked as a duplicate of 50660 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.