Garbage Characters Displayed for some sites

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Eric Murphy, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
I ran across 2 pages tonight that are not displaying the web page.

http://www.yahoo.com
http://www.giga-byte.com/Motherboard/Support/Manual/Manual_List.htm

The View Source displays the same data. If I reload the pages, different (but
similar) garbage gets displayed.

I was doing some hardware work on my computer tonight, and thought maybe that
started this glitch somehow. However, IE and Netscape 7.1 render the pages fine.

I am using tonight's build and originally ran across this from a build that is
about a month old I think. Both have the same problem.

Weird wild stuff.
(Reporter)

Comment 1

14 years ago
Created attachment 148591 [details]
garbage for yahoo
(Reporter)

Comment 2

14 years ago
Created attachment 148592 [details]
giga-byte.com

Comment 3

14 years ago
Bug 241085 might be related/dupe?
(Reporter)

Comment 4

14 years ago
Also, I am on Windows XP. I just restarted the computer and everything, still
does it for those URLs. I can't find any others that do it.

If this is hardware originated, I wonder what it could be. I replaced an IDE
cable, and power supply is all. I know yahoo.com has worked for me in the past.
(Reporter)

Comment 5

14 years ago
I looked at that bug before submitting, and reloading does not work. It just
changes the garbage data somewhat. At least their garbage data has some data in
there as part of the HTML, this does not.
(Reporter)

Comment 6

14 years ago
I tried those sites again today, and now they load!

I have no clue on how to reproduce this bug :-(

Comment 7

14 years ago
I get the same thing, on Gigabyte's site and also Intel's (
http://downloadfinder.intel.com/scripts-df/support_intel.asp?iid=HPAGE+header_support_download&
) -- their support link from the homepage.  No Problems in IE.  Clean install of
XP, plus updates, wouldn't surprise me to find an update is the cause.

Comment 8

14 years ago
Update; this is tied to UTF-16 encoding.  These pages are shown as gatbage in
utf-16, changing to view->character encoding->western and they display correctly.

Comment 9

13 years ago
-->WORKSFORME with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050602 Firefox/1.0+

Please reopen it if you still have the same problem with the latest nightly
build and the safe-mode.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.