page and flash plugin stops loading

RESOLVED WORKSFORME

Status

()

Core
Networking
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: R.K.Aa., Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-03-15, URL)

(Reporter)

Description

14 years ago
day old trunk CVS, Linux - Gtk2+xft

Trying to go to http://www.chanel.com/fashion/en-gb/ the pageload and loading of
plugin halts while this displays in statusbar:
"Transferring data from statse.webtrendslive.com..."

On one occation Mozilla froze up completely and had to be killed.
Seems like its waiting for something.
Guessing networking component.

Not blocking cookies or scripts (only popups, of which there are none in this case.)

Page and same plugin loads fine in Opera

Comment 1

14 years ago
confirming: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a) Gecko/20040515

opened from URL: field above, loading in a new tab in the background.
When I switched to the tab, I saw a small loading... sign following my mouse.
DUN didn´t show traffic, system was normal, other tabs were working.I´m not
blocking anything, HTTP1.1, Keep-Alive enabled, Pipelining disabled.

Then installed LiveHTTPHeaders, restarted Mozilla, LiveHTTPHeaders, and loaded
the bug, and the URL in anew tab, looked at the headers, and when I switched to
the page, it had loaded. Trying to repeat this failed some times, succeeded only
once. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 2

14 years ago
tested with Mozilla 1.0.2, 1.3.1, 1.4.2, and shockwave flash 7.0 r19 on Win98
Same behaviour.
When I used Netscape 4.79, it crashed.
In Netscape 4.79 I see in the status line: 
Loading Plugin...
Starting Java...


Java Plug-in 1.4.2_04 for Netscape Navigator (DLL Helper)

Comment 3

14 years ago
Maybe this relates to processor speed, network speed or so?
Previous test were done on a Celeron 333 with 96 MB RAM, ISDN 64 kbit/sec

and it is WFM with some of these browsers on an Athlon XP1600+ with 512 MB RAM, DSL.
jst may want to take this one....

/be
Hmm, I had a look at what's going on here, and I'm not actually able to
reproduce this problem on my relatively fast Win32 laptop, but I'll make an
attempt at reproducing it on my old dual PII-333 linux system too. But the
interesting thing to note here is that loading that page doesn't hit any of the
code which I made significant changes to. Obviously it hits the
OnDataAvailable() method in ns4xPluginStreamListener, but it doesn't hit the
cases I changed, i.e. we don't hit the case where we're feeding the plugin data
faster than it can consume it, so we never start the data pump etc.
(Reporter)

Comment 6

14 years ago
P4/1.8 Northwood, 512MB RAM, 1600/512 Kbps ADSL connection
Linux or Win?
(Reporter)

Comment 8

14 years ago
see comment 0: Linux
(Reporter)

Comment 9

14 years ago
if you test on Linux you may also see bug 242122 on the Chanel site.
But unlike in this bug, the sites in bug 242122 do load completely, allthough
the plugin area is partly obscured by "something"

Comment 10

14 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a1) Gecko/20040520

seems it is loading if called directly:
http://www.chanel.com/fashion/en-gb/index_plug.php

I started looking at the source files:
view-source:http://www.chanel.com/fashion/en-gb/ gives:

<frameset rows="100%,*" frameborder=0 border=0 framespacing=0>
	<frame name="main" src="./index_detect.php" .....
	<frame name="scripts" src="../html/blank.php" .....

if the first frame gets 100%, does a star and a 2nd frame amke sense?

view-source:http://www.chanel.com/fashion/html/blank.php
<body bgcolor="#FFFFFF" marginwidth=0 leftmargin=0 topmargin=0 marginheight=0>
</body>


view-source:http://www.chanel.com/fashion/en-gb/index_detect.php
<HTML>
<HEAD>
<TITLE>C H A N E L</TITLE>
<SCRIPT TYPE="text/javascript" SRC="../js/flash_detect.js"></SCRIPT>
<SCRIPT LANGUAGE="VBScript" SRC="../js/flash_detect.vbs"></SCRIPT>
</HEAD>
<body bgcolor="#FFFFFF" topmargin=0 leftmargin=0 marginwidth=0 marginheight=0>
<SCRIPT LANGUAGE="javascript">
if(parent.frames.length==0) {
				parent.location.href="/fashion/en-gb/index.php";
} else {
	var MM_FlashSnifferURL = "/fashion/images/common/detect_flash.swf";
				
MM_FlashDispatch('/fashion/en-gb/index_plug.php','6.0',false,'/fashion/en-gb/index_noplug.php',!MM_FlashUserDemurred(),'/fashion/en-gb/index_noplug.php','/fashion/en-gb/index_noplug.php',false,false);
}
</SCRIPT>
</BODY>
</HTML>

view-source:http://www.chanel.com/fashion/js/flash_detect.js
view-source:http://www.chanel.com/fashion/js/flash_detect.vbs
view-source:http://www.chanel.com/fashion/en-gb/index.php same as
http://www.chanel.com/fashion/en-gb/


that´s the file seen endless loading:
view-source:http://www.chanel.com/fashion/en-gb/index_plug.php
http://www.chanel.com/fashion/en-gb/index_plug.php

and that one gives a short error message that flash 6 is needed:
view-source:http://www.chanel.com/fashion/en-gb/index_noplug.php
http://www.chanel.com/fashion/en-gb/index_noplug.php

Comment 11

14 years ago
Looks like being a dupe of this one: Bug 244271 Flash flickers
http://www.alveran.org/?pageID=10&navBereich=Neuigkeiten

It is just a guess, both are framesets having 100% combined with  some number of
cols, rows, or a star, and have flash 6. Loading the flash directly succeeds.

Updated

12 years ago
Assignee: darin → nobody
QA Contact: benc → networking

Comment 12

9 years ago
do you see this problem using latest version of flash (10) and firefox?
Whiteboard: closeme 2009-03-15
Works for me, Firefox 3.0.9pre (2009032804) with Flash 10.0 r12 on Linux.

Please reopen the bug if you can reproduce it in Firefox 3 with
Flash 10 (or later).  Thanks.

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.