If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Plain text reply: too much space above quote text

VERIFIED WORKSFORME

Status

MailNews Core
Composition
P3
normal
VERIFIED WORKSFORME
18 years ago
9 years ago

People

(Reporter: fenella, Assigned: harishd)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Linux Redhat 6.0 (2000-01-19-08 M13)
Win32 (2000-01-19-09 M13)

Summary: [Regression]Plain text reply: too much space between original sender
and original quoted text.
Steps:
1. From the Edit|Account Setup, uncheck "Compose messages using html" to set up
a plain text editor,
2. From the Inbox folder, select a message,
3. click on the Reply button, a plain text compose window comes up.

Actual result: Notice that there exists too much space between the original
sender and the original quoted text, about 3 lines space which does not look
good.  Eg:

qatest38 wrote:



> aaaaa
> bbbbbb
> ccccc

Expected result: No space between them

qatest38 wrote:
> aaaaa
> bbbbbb
> ccccc

This exists when using plain text editor on both Win_nt and Linux. Have not
tested Mac yet.
(Reporter)

Comment 1

18 years ago
Additional observation: when I view the reply message, it added 3 more line
space between original sender and quoted text.

Comment 2

18 years ago
akkana?  would this be in your area?

Updated

18 years ago
Assignee: ducarroz → harishd

Comment 3

18 years ago
Actually, I bet it's harish -- he introduced an
extra-whitespace-at-beginning-of-document problem a few days ago.  He has a fix
ready.
(Assignee)

Updated

18 years ago
Target Milestone: M14
(Assignee)

Comment 4

18 years ago
Fenella, could you please verify this for me...this might have got FIXED.
(Reporter)

Comment 5

18 years ago
Harish, today's build has a bug in compose.  I'll use tomorrow's build to 
re-test this bug.
(Reporter)

Comment 6

18 years ago
Linux, Win32 and Mac (2000-01-28-12 M14)
No. This problem still exists on all platforms.
(Assignee)

Comment 7

18 years ago
Moving to M15.
Target Milestone: M14 → M15

Updated

18 years ago
Keywords: regression
Summary: [Regression]Plain text reply: too much space above quote text → Plain text reply: too much space above quote text

Updated

18 years ago
QA Contact: lchiang → fenella

Comment 8

18 years ago
Actually, to be 4xp (and more readable), it shouldn't be

qatest38 wrote:
> aaaaa
> bbbbbb
> ccccc

It should be

qatest38 wrote:
>
> aaaaa
> bbbbbb
> ccccc

Comment 9

18 years ago
Personally, I hate that extra space in 4.x and always edit it out.  Just to show
that where mail/news formatting, no two people agree on anything. :-)

Comment 10

18 years ago
The reasoning for an extra `>' line after the attribution is that the quoted 
section might be more than one paragraph (in fact, it usually is), and the 
attribution and the first quoted paragraph shouldn't look more connected with 
each other than the first quoted paragraph and the second quoted paragraph do.

But whether the extra `>' is implemented or not, it should not be a pref -- that 
would be silly. (Just thought I'd jump on that possiblity before someone 
suggested it.:-)

Comment 11

18 years ago
bulk move to M16. Not an M15 stopper.  If you disagree, pls comment in bug and 
cc: selmer@netscape.com
Target Milestone: M15 → M16
(Assignee)

Comment 12

18 years ago
I don't see any extra spacing....could you please verify this bug. Thanx.

Comment 13

18 years ago
I no longer see any extra spacing here.  Does anyone else?
(Reporter)

Comment 14

18 years ago
Linux (2000-04-21-08 M16)
Win32 (2000-04-21-09 M16)
Mac (2000-04-21-08 M16)
I re-test this bug. I do not see the problem any more. Mark it worksforme.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 15

18 years ago
verified it.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.