The default bug view has changed. See this FAQ.

*,800,* frameset on 1920x1200 screen only uses 800 pixels when increasing text size

RESOLVED DUPLICATE of bug 4821

Status

()

Core
Layout: HTML Frames
--
enhancement
RESOLVED DUPLICATE of bug 4821
13 years ago
13 years ago

People

(Reporter: Ben.Verloop, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

It would be great if an option can be added to Mozilla/Firefox to use the empty
space left and right of the frame which contains the content in case I increase
the text size. Now a *,800,* frameset on a 1920x1200 screen consistently (as it
should) uses 800 pixels of the 1920 available, and 1120 pixels are unused. This
is OK to start with, but if I increase the text size with ctrl+ it would be
great if the unused space becomes smaller, and the text size frame increases.

Reproducible: Always
Steps to Reproduce:
1. Find a wide screen, at least 1280 pixels
2. Go to http://www.webwereld.nl
3. Increase the text size with ctrl+


Actual Results:  
Note that the width of the used part of the screen doesn't change. Both on the
left and the right of the screen there is a large area unused. Also the number
of letters on a line in the used part decreases when increasing the text size.
All of this is caused by the fixed width of the frame.

Expected Results:  
An option to expand the fixed width frame into the unused left and right area of
the screen. So if the text size is increased by 25% the frameset *,800,* on a
1920 pixels width window should be interpreted as *,1000,* until the fixed width
pixel recalculation becomes higher than the width of window. Before activating
this option, the browser should determine whether or not the space on the left
and right is indeed unused.

I have a beautifull 1920x1200 screen with only 792 pixels being used :-(. I know
it is the website with the fixed 792 pixels width frame which is causing this
behaviour, but the above described option can make the usage of the screen width
better.
And how does mozilla know a frameset is unused?
(Reporter)

Comment 2

13 years ago
There are a zillion ways of determining this. A three step approach could be:
1. If there is text on the page, it is not empty
2. If there is a image on the page, which doesn't only contain the same color as
the background of the page, the page is not empty
3. Assume the page is empty

Eg. <html><head><title></title></head><body BGCOLOR="#FFFCE4"><br></body></html>
is an empty .html page.

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 4821 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.