Closed Bug 24385 Opened 25 years ago Closed 25 years ago

crash in StripeTimer::Notify closing mail window while checking for new mail

Categories

(Core :: XUL, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: cbegle, Assigned: eric)

References

Details

(Keywords: crash, Whiteboard: [PDT+] Fixed awaiting checkin.)

BuildID:  2000011415
Platform: NT4.0
Setup:    Several POP3 accounts, one news server.

Mozilla crashed when I closed the Mail window while it was still checking for
mail.

Reproduce:
1. In the Mail window, select a POP account.
2. Click Get Msg icon.
3. While Mail is still displaying the "Host contacted..." message, close
   the Mail window.
   -> crash.

I'm just guessing on the component based on the the last message in the console
window, which was:

OnUnload from XUL
Clean up ...
JavaScript Error: uncaught exception: [Exception... "Component returned
failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIMessenger.SetWin
dow]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS
frame :: chrome://messenger/content/msgMail3PaneWindow.js :: OnUnloadMes
senger :: line 214"  data: no]

I'll rebuild and try to reproduce and provide a stack trace.
Assignee: phil → mscott
Scott, can you check this out?
QA Contact: lchiang → esther
See bug 24466.  It might be the same crash and in that bug report there is a
stack trace.
Component: Front End → XP Toolkit/Widgets
Product: MailNews → Browser
ooh my crash is in gkhtml.dll same stack trace.

StripeTimer::Notify(nsITimer * 0x035a2990) line 185 + 13 bytes
TimerImpl::Fire(unsigned long 60167203) line 317
TimerImpl::ProcessTimeouts(unsigned long 60167203) line 191
FireTimeout(HWND__ * 0x00000000, unsigned int 275, unsigned int 19152, unsigned
long 60167203) line 105 + 9 bytes
USER32! 77e712a4()
nsAppShellService::Run(nsAppShellService * const 0x00c45900) line 466
main1(int 1, char * * 0x00c244b0) line 598 + 32 bytes
main(int 1, char * * 0x00c244b0) line 691 + 13 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77f1ba3c()

24466 has two bugs in it.  let's let 24466 be for the the login problem.

since the crash is in GKHTML.DLL (a layout bug and and not mail news) it makes
sense to split the problems in 24466 up.  I'll switch the product/component of
this bug and make a note in the other.
Assignee: mscott → evaughan
Summary: crash closing mail window while checking for new mail → crash in StripeTimer::Notify closing mail window while checking for new mail
reassigning to evaughan since it looks like this is his code
*** Bug 24441 has been marked as a duplicate of this bug. ***
I just mark my bug as a dup of this one. Let me now if I can help...
Adding myself to cc: list
nominate for Dogfood for PDT team to review.  As more people use the product and 
try to do many things at once, this crash can be easy to run across.  This turns 
out to be reproducible on all platforms (as per duplicate bug that got filed)
Severity: normal → critical
OS: Windows NT → All
Hardware: PC → All
Summary: crash in StripeTimer::Notify closing mail window while checking for new mail → [DOGFOOD]crash in StripeTimer::Notify closing mail window while checking for new mail
Putting on PDT- radar.  But adding beta1 keyword to get a fix soon.  
Keywords: beta1
Whiteboard: [PDT-]
targeting
Status: NEW → ASSIGNED
Target Milestone: M14
*** Bug 23717 has been marked as a duplicate of this bug. ***
Clearing PDT- since this is nominated for beta1 and needs PDT re-review.
Whiteboard: [PDT-]
clearing DOGFOOD
Summary: [DOGFOOD]crash in StripeTimer::Notify closing mail window while checking for new mail → crash in StripeTimer::Notify closing mail window while checking for new mail
Putting on PDT+ radar for beta1.
Whiteboard: [PDT+]
Adding "crash" keyword to all known open crasher bugs.
Keywords: crash
Whiteboard: [PDT+] → [PDT+] Fixed awaiting checkin.
Fixed. Progressmeter no longer uses a timer.
Status: ASSIGNED → RESOLVED
Closed: 25 years ago
Resolution: --- → FIXED
Using build 2000-02-18-09 on win98 and 2000-02-19-08 on linux and mac and 
running this basic scenario, this is fixed.  I created a new profile, added a 
new pop account with 156 msgs.  I did a Get Msg, gave correct password and while 
the msgs were loading I closed the Mail window.  I opened the Mail window again 
saw that only 40 msgs were downloaded, clicked on Get Msg to start downloading 
the rest.  I interrupted the download by closing the mail window 2 more times 
and didn't crash.  Note when I closed the browser was still up so it didn't 
close the app (not sure if that's part of the test).  Christine, if you wouldn't 
mind trying this again, just to make sure I'm not missing something.  I will 
verify after I try the duplicates too.
verified with a build from 2/21/2000
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.