M17 FF09x crash [@ dxmasf.dll] viewing windows media files

RESOLVED WORKSFORME

Status

Plugins Graveyard
Windows Media Player (Microsoft)
--
critical
RESOLVED WORKSFORME
14 years ago
2 years ago

People

(Reporter: jay, Unassigned)

Tracking

({crash, topcrash})

x86
Windows XP
crash, topcrash

Details

(crash signature)

(Reporter)

Description

14 years ago
There are a lot users crashing while dealing with their junk mail folders.  The
stack isn't very useful, but enough people are seeing this crash for us to take
a closer look.

Here is the latest from Mozilla 1.7 rc1 Talkback data:
Count   Offset    Real Signature
[ 10   dxmasf.dll + 0xd25e (0x6bf5d25e) 9724fdbb - dxmasf.dll + 0xd25e
(0x6bf5d25e) ]
[ 1   dxmasf.dll + 0xd25e (0x6bf5d25e) de3c26b3 - dxmasf.dll + 0xd25e (0x6bf5d25e) ]
[ 1   dxmasf.dll + 0xd25e (0x6bf5d25e) d11fa2e6 - dxmasf.dll + 0xd25e (0x6bf5d25e) ]
 
     Crash date range: 07-MAY-04 to 13-MAY-04
     Min/Max Seconds since last crash: 32 - 915479
     Min/Max Runtime: 114775 - 915479
 
     Count   Platform List 
     12   [Windows NT 5.1 build 2600]   
 
     Count   Build Id List 
     12   2004042109
 
     No of Unique Users         8
 
 Stack trace(Frame) 

	 dxmasf.dll + 0xd25e (0x6bf5d25e)  
	 Quartz.dll + 0x58b70 (0x35558b70)  
	 Quartz.dll + 0x55330 (0x35555330)  
	 Quartz.dll + 0x6e2b2 (0x3556e2b2)  
	 0x3042e920   
 
     (46928)	URL: Reading e-mail  deleting SPAM.
     (46926)	Comments: Reading e-mail  and clicking Junk button for the SPAM.
     (44002)	Comments: One specific Spam mail does crash the Mozilla when moving
preview pane displaying from this mail to another one.  The delay between moving
and crash message is cca 0.5 sec.
     (43995)	Comments: I click to one spam mail to see it in the preview pane.
     (43990)	Comments: Listing in mails.  This occur after I saw a spam mail in
junk folder by moving to one of mine other subfolders  
     (43077)	Comments: Downloading mail
     (42963)	Comments: - Selected all mails in my trash folder  - deleted them 
- when to another folder to review an unread e-mail
     (42106)	Comments: Reading e-mail in Mozilla e-mail
 
====================================================================================================
     Count   Offset    Real Signature
[ 4   dxmasf.dll + 0xd25e (0x1ff0d25e) ef6f6f0f - dxmasf.dll + 0xd25e (0x1ff0d25e) ]
 
     Crash date range: 10-MAY-04 to 14-MAY-04
     Min/Max Seconds since last crash: 779 - 214035
     Min/Max Runtime: 20435 - 547300
 
     Count   Platform List 
     4   [Windows NT 5.0 build 2195]   
 
     Count   Build Id List 
     4   2004042109
 
     No of Unique Users         4
 
 Stack trace(Frame) 

	 dxmasf.dll + 0xd25e (0x1ff0d25e)  
	 Quartz.dll + 0x575d4 (0x355575d4)  
	 Quartz.dll + 0x52238 (0x35552238)  
	 Quartz.dll + 0x6c9ca (0x3556c9ca)  
	 0x3caae920   
 
     (46722)	Comments: reading email - had just clicked on a new message in
another folder
     (43099)	Comments: downloading a large amount of email  and marking some as
junk in the inbox

Comment 1

14 years ago
quartz.dll and dxmasf.dll are part of MS DirectShow
It looks like it's related to the content of the spam mail ?
Should be interesting to know if the HTML is sanitized and if remote images are
displayed.
(Reporter)

Comment 2

14 years ago
Still around with rc2.  Still trying to reproduce, but no luck.  If anyone does
crash, please include more info about the email you were working with (and if
possible, maybe even attach it here?).
Summary: M17rc1 crash [@ dxmasf.dll] working with junk mail → M17rc2 crash [@ dxmasf.dll] working with junk mail
(Reporter)

Comment 3

14 years ago
Updating summary with M17 and FF09x since this continues to be a topcrasher for
the latest releases.  Although this first appeared as a mail related crash,
Talkback data now shows that it's a more general crash when viewing media files
on websites (and also mail content as originally reported).  

A lot of comments mention windows media player and the most common url is
www.gamespot.com:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=dxmasf.dll&vendor=All&product=All&platform=All&buildid=&sdate=&stime=00%3A00%3A00&edate=&etime=23%3A59%3A59
Component: Filters → Plug-ins
Product: MailNews → Browser
Summary: M17rc2 crash [@ dxmasf.dll] working with junk mail → M17 FF09x crash [@ dxmasf.dll] viewing windows media files
Version: Trunk → 1.7 Branch
(Reporter)

Updated

14 years ago
Assignee: sspitzer → nobody
QA Contact: core.plugins
(Reporter)

Comment 4

14 years ago
Only 37 of these crashes in over 80K incidents for Firefox 1.0 PR1 (0 crashes in
Thunderbird 0.8), so marking this worksforme.  If anyone is able to reproduce
this crash or sees a large number showing up again in Talkback data, please feel
free to reopen.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
bug 282116 has a (semi-)reliable testcase that has the same stacktrace as this
bug. It crashes for me on trunk builds, but probably also crashes on Moz1.7 builds.

Updated

8 years ago
Component: Plug-ins → Windows Media Player (Microsoft)
Product: Core → Plugins
QA Contact: plugins → microsoft-wmp
Version: 1.7 Branch → 6.x
(Assignee)

Updated

7 years ago
Crash Signature: [@ dxmasf.dll]
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.