default encoding is not utf-8 for application/xhtml+xml documents

VERIFIED DUPLICATE of bug 240321

Status

()

VERIFIED DUPLICATE of bug 240321
15 years ago
15 years ago

People

(Reporter: vr, Assigned: smontagu)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

If document is served with application/xhtml+xml encoding, and
autodetection-->universal is off and no encoding is supplied in HTTP headers
sent by server or in the <meta> tag, and <?xml ..?> declaration is omitted,
default encoding is not treated as utf-8, as requered by REC-XML 3.1.1. 

Reproducible: Always
Steps to Reproduce:
1. Make sure that encoding is not utf-8 and autodetection of encoding is
switched off.
2. Serve some utf-8 document with non-ASCII symbols (e.g. Cyrillic), which does
not have an xml declaration and no "Content-type" HTTP header or <meta> tag,
with an application/xhtml+xml MIME type.


Actual Results:  
Enjoy the scary rendering of utf-8 characters as if they would be characters in
the chosen encoding.

Expected Results:  
Browser must use UTF-8 unconditionally for XML documents when no encoding
indication is given.

This was checked with russian utf-8 documents, I have no knowledge whether
glyphs from the other languages are similarly misinterpreted.

It does switches to utf-8 when the document is served as text/html though,
disregarding autodetection settings. application/xhtml+xml MIME type should work
in a similar way.
Fixed in current builds.

*** This bug has been marked as a duplicate of 240321 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.