GLib-GObject-CRITICAL **: file gobject.c: line 1400 (g_object_get_data): assertion `G_IS_OBJECT (object)' failed

RESOLVED DUPLICATE of bug 242768

Status

SeaMonkey
MailNews: Message Display
--
critical
RESOLVED DUPLICATE of bug 242768
14 years ago
13 years ago

People

(Reporter: Calum Mackay, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a) Gecko/20040515 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a) Gecko/20040515

I've been seeing mailnews fall over when sending a plaintext message:

(Gecko:1292): GLib-GObject-WARNING **: invalid uninstantiatable type `<unknown>'
in cast to `GtkWidget'

(Gecko:1292): GLib-GObject-WARNING **: invalid uninstantiatable type `<unknown>'
in cast to `GObject'

(Gecko:1292): GLib-GObject-CRITICAL **: file gobject.c: line 1400
(g_object_get_data): assertion `G_IS_OBJECT (object)' failed
/usr/local/src/mozilla/mozilla/mozilla-2004051506/run-mozilla.sh: line 423: 
1292 Segmentation fault      "$prog" ${1+"$@"}

The mail is sent correctly, and even copied to the sent mail folder. The crash
seems to occur as the compose window is removed. 100% reproducible. Happens in
both mailnews & thunderbird.

The problem seems to have started with my nightly build of 20040506:

/usr/local/src/mozilla/thunderbird/thunderbird-2004050606/thunderbird  

(Gecko:5151): GLib-GObject-WARNING **: invalid cast from `(null)' to `GtkWidget'

(Gecko:5151): GLib-GObject-WARNING **: invalid cast from `(null)' to `GObject'

(Gecko:5151): GLib-GObject-CRITICAL **: file gobject.c: line 1400
(g_object_get_data): assertion `G_IS_OBJECT (object)' failed
/usr/local/src/mozilla/thunderbird/thunderbird-2004050606/run-mozilla.sh: line
423:  5151 Segmentation fault      "$prog" ${1+"$@"}

and every build since then has the problem. I'm now sticking with 20040505 which
is fine.

I haven't yet built a stripped, non-optimised, version to get a useful stack,
but can do if necessary.

Since it's been around so long for me (I've only just noticed having been away)
and yet I don't see it reported, perhaps something odd about my system that's
tickling this bug?

about:buildconfig

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.3.3 (Debian 20040401) 	-Wall -W -Wno-unused -Wpointer-arith
-Wcast-align -Wno-long-long -pedantic -pthread -pipe
c++ 	gcc version 3.3.3 (Debian 20040401) 	-fno-rtti -fno-exceptions -Wall
-Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic
-fshort-wchar -pthread -pipe -I/usr/local/X11R6/include

Configure arguments
--disable-debug '--enable-optimize=-O2 -march=i686' --enable-strip
--enable-strip-libs --disable-tests --enable-crypto
--enable-default-toolkit=gtk2 --enable-xft --enable-xterm-updates
--x-includes=/usr/local/X11R6/include --x-libraries=/usr/local/X11R6/lib
--with-system-jpeg --with-system-zlib --with-system-png --with-system-mng
--enable-calendar --enable-extensions=all --enable-ldap-experimental
--enable-svg --enable-svg-renderer-libart 

Reproducible: Always
Steps to Reproduce:
1.See other comments.
2.
3.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 242768 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

14 years ago
mmm, disappointing that bugzilla's default searching didn't find that bug for
me, even though my search term was in it.

thanks, sorry
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.