[PP] Links are not underlined correctly

VERIFIED FIXED in M2

Status

()

P2
normal
VERIFIED FIXED
20 years ago
12 years ago

People

(Reporter: pierre, Assigned: davidm)

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
Another problem with fonts and attributes...

Go to www.yahoo.com, for instance.
==> Look at the links: the underline touches the text. It should be one pixel
below.
(Reporter)

Updated

20 years ago
OS: All
Summary: [PP] Link are not underlined correctly → [PP] Links are not underlined correctly
(Assignee)

Comment 1

20 years ago
in nsFontMetricsMac there is a function called GetUnderline which is supposed to
return the offset to the base line
 currently it reads
	 aOffset = NSToCoordRound(-  float(mMaxDescent / 2)  +  dev2app );
I have no idea where this equation comes from but with small fonts mMaxDescent is
small enough to give a 0 offset. Setting the offset to (- dev2app) gives a 1
pixel space between the base line and the underline. I don't know enough about
fonts to say exactly where the underline is supposed to be.
(Reporter)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

20 years ago
I fixed it. The formula was wrong: it should be "aOffset = - dev2app".

Note: the underline is still not displayed exactly as it should (at least on the
Mac) because it's not a broken line under letters like pqQjg... I opened bug
#2445 and assigned it to Kipp.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 3

20 years ago
Verified fixed in Jan 21 Mac build.

Updated

20 years ago
Status: VERIFIED → REOPENED
OS: All → Mac System 8.5
QA Contact: 4130

Comment 4

20 years ago
Rather than open another bug with the same summary I chose to reopen this one. This bug differs in tht it isn't across the board.
i've only found it at one site so far.
On the Mac with the 01/29/99 build:
go to www.altavista.com none of the underlined links have anyspace between the text of the link and the underline itself.
this page uses <font face= arial, helvitica> but I don't think that's anything special.

I've only been able to reproduce this bug on G3's, not on PPC's running 8.5.1 but w/o the G3 chip, e.g. a 9600/300. It of course,
works fine on Linux and Windows.

Updated

20 years ago
(Reporter)

Comment 5

20 years ago
That's weird. It works for me on a PPC 225 with 8.5.1. Did you check on several
G3s? Did you check with Nova on these machines? Does it have anything to do with
your settings under Control Panels | Appearance | Fonts?
(Assignee)

Comment 6

20 years ago
I can reproduce on my 9600 under 8.5. It looks okay under Nova ( of course the
Old layout engine did real underlining  ). Since it is the same font as Yahoo (
arial, helevetica ) I am a bit confused. It might be interesting to see if you
have Arial installed ( I believe IE installs it ). I'll look into it some more.

Comment 7

20 years ago
c'mon guys.
Yes I checked on several G3's. Yes I crosschecked with Nova.
All of the machines have arial installed (including the 9600 I couldn't repro on).

The iMac's I checked on all have the 'font for views' set to geneva10 in the appearance control panel. I have mine set to
verdana9.
(Reporter)

Comment 8

20 years ago
It's ok: since David could reproduce it, getting fix is just a matter of nano
minutes.
(Assignee)

Comment 9

20 years ago
Here is some simplified HTML which reproduces the problem

<html>
<sup>TM</sup>
<a href="http://jump.altavista.com/cgi-bin/FF"><b>AV Family Filter</b></a> -
</BODY></HTML>
If you remove the <sup> tags it works.
After looking at the math, it appears to me that in nsFontMetrics::GetUnderline()
a NSToCoordRound should be done before assigning to aOffset and aSize so the code
looks like
  aOffset = -NSToCoordRound( dev2app );
  aSize   = NSToCoordRound( dev2app );

Updated

20 years ago
Resolution: FIXED → ---

Comment 10

20 years ago
clearing Fixed resolution
(Reporter)

Comment 11

20 years ago
David, you're right about the math: you can add the macros. I'm confused about
the problem the <sup> tag, I would expected it to be cross-platform.
(Assignee)

Updated

20 years ago
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

20 years ago
checked the fix in.

Comment 13

20 years ago
installing myself as QA Contact for sevaral bugs at once

Comment 14

20 years ago
Inserting Milestone info.

Updated

20 years ago
QA Contact: 4130 → 1698

Comment 15

20 years ago
LEts mark this VERIFIED_FIXED, Eli or Claudius...

Updated

20 years ago
Status: RESOLVED → VERIFIED
QA Contact: 1698 → 4130

Comment 16

20 years ago
verified fixed for MacMonkey99034
setting QA Contact back to myself
You need to log in before you can comment on or make changes to this bug.