Vertical scroll an iframe without pressing the mouse button

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: ajunne, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Bug Flags:
blocking1.8a2 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040517 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040517 Firefox/0.8.0+

When a page contains one or more iframes, and the iframes have a vertical scroll
bar, dragging the scroolbar all the way down with the mouse while holding the
left mousebutton pressed, then moving the mouse left or right away from the
scrollbar keeps the scrollbar scrolling even though you did not select it
anymore with the mouse.

Reproducible: Always
Steps to Reproduce:
This one is very picky and requires some precision mouse movement, i'll try to
be as accurate as possible:

0. Open up a webpage containing an iframe (the one i'm typing in right now on
the bugzilla server
(http://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox&format=guided) will
do quite well
1. Click on the vertical scrollbar of the iframe, hold the left mouse button and
drag it all the way down. Do not release the mousebutton yet!
2. While keeping your mousebutton down, move your mouse left into the iframe (or
right outside of it), either way not hovering over the scrollbar anymore. Now
release the mouse button.
3. Now with the mousebutton not pressed, hover over the scrollbar you just
dragged down. You will see that the scrollbar follows your mouse even though you
are not dragging it!
Actual Results:  
The scrollbar follows the mouse even though the left mousebutton is not pressed.

Expected Results:  
The scrollbar should not follow your mouse when the left mousebutton is not pressed.
(Reporter)

Updated

15 years ago
Summary: Scrolling down over an iframe does not stop even when mouse button is not pressed → Vertical scroll an iframe without pressing the mouse button
(Reporter)

Updated

15 years ago
Severity: normal → major

Comment 1

15 years ago
Does not happen in: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a)
Gecko/20040510

But I can confirm in: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a)
Gecko/20040517 Firefox/0.8.0+

Looks like it's Firefox specific (which is rather surprising).
Severity: major → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

15 years ago
Keywords: regression
can also replicate in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a)
Gecko/20040518
Component: General → GFX
Product: Firefox → Browser
Version: unspecified → Trunk
(Reporter)

Comment 3

15 years ago
It seems to be fixed in:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040526
Firefox/0.8.0+

Or at least, I can't reproduce it anymore on the same site i found the bug on...
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a1) Gecko/20040520] (release) (W98SE)

v1.8a1 is broken (per comment 0 steps). [and other real life cases]

From comments:
Broken between 20040510 and 20040517 !?
Fixed between 20040520 and 20040526 !?
Flags: blocking1.8a2?

Updated

15 years ago
Flags: blocking1.8a2? → blocking1.8a2-

Updated

15 years ago
Assignee: firefox → general
QA Contact: ian

Comment 5

11 years ago
This was fixed a long time ago, no? Propose REVOLVED FIXED.
R.WorksForMe, per comment 3...
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.